1079. Total Sales of Supply Chain (25)

该博客讨论了一个供应链模型,其中产品从根供应商通过一系列零售商和分销商传递,每个环节价格增加r%。您需要计算所有零售商的总销售额。输入包含供应链成员数量、起始价格和价格增长率,以及每个成员的下游分销商或零售商信息。输出应显示预期的零售商总销售额(精确到小数点后一位)。请注意处理可能的销售量数据,并避免数值计算误差。
摘要由CSDN通过智能技术生成

1079. Total Sales of Supply Chain (25)

时间限制
250 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the total sales from all the retailers.

Input Specification:

Each input file contains one test case. For each case, the first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N-1, and the root supplier's ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

Ki ID[1] ID[2] ... ID[Ki]

where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. Kj being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after Kj. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 1010.

Sample Input:
10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3
Sample Output:
42.4

1,这次考试是不是跟我有仇

2.用double不用浮点~]

3.公式错了

#include<iostream>
#include<vector>
#include<math.h>
using namespace std;
	
vector<vector<int>>a;

int pro[100001]={0};
int level[100001]={0};
double r,base;
int N;

void leit(int m){
	int n;
	n=a[m].size();
	for(int i=0;i<n;i++){
		if(level[a[m][i]]==0){
			level[a[m][i]]=level[m]+1;
			leit(a[m][i]);
		}
	}
}

int main(){
	//freopen("in.txt","r",stdin);
	scanf("%d%lf%lf",&N,&base,&r);
	r=r/100+1;
	a.resize(N);
	int i=0;
	//pro[1]=3;
	for(i=0;i<N;i++){
		int nn;
		scanf("%d",&nn);
		if(nn==0){
			int pp;
			scanf("%d",&pp);
			pro[i]=pp;
		}else{
			for(int j=0;j<nn;j++){
				int temp;
				scanf("%d",&temp);
				a[i].push_back(temp);
			}
		}
	}
	level[0]=1;
	leit(0);
	int j;
	double sum=0;
	for(i=0;i<N;i++){
		if(pro[i]!=0){	
//			sum=sum+pro[i]*(level[i]-1)*r);
			//cout<<(level[i]-1)*r+1<<endl
			sum=sum+pro[i]*pow(r,level[i]-1);

		}
	}
	printf("%.1f",sum*base);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值