「1079」Total Sales of Supply Chain

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)– everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the total sales from all the retailers.

Input Specification:

Each input file contains one test case. For each case, the first line contains three positive numbers:  , the total number of the members in the supply chain (and hence their ID’s are numbered from 0 to N−1, and the root supplier’s ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

where in the i-th line, Ki​ is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID’s of these distributors or retailers.  ​ being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given aftter ​. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed  .

Sample Input:

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3

Sample Output:

42.4

Ω

给出一个经销商树,根节点是最大供应商,叶子节点是零售商,其余供应商都从父供应商进货,然后卖给自己下面的供应商。每个供应商(包括零售商)出售价格都会比自己买入的价格高出 ,告知所有零售商的进货量,计算所有零售商的预期收入总和。

不难看出,零售商出售价格只与自身所处的深度有关,因此我们可以用BFS,每次遍历一层节点,将该层中的叶子节点进货量相加,最后 即为该层零售商的预期收入。

遍历完整颗树后再将得到结果乘以最大供应商的出售价格 即可。

无意中还发现其实"%.nf"这种浮点数格式化也是四舍五入,重塑世界观。之前还有一篇博客专门分析四舍五入时还以为是浮点数运算中的精度损失,未曾想是直接给四舍五入了,玩完,得补课去了。不过他的四舍五入机制因为浮点数精度的问题会有点差异,详情可见C语言printf函数%.2f输出为什么四舍五入实现机制不同?

⚠️+0.5操作是浮点数转int时的操作,上面的格式化默认是四舍五入。


🐎

#include <iostream>
#include <vector>
#include <cmath>

using namespace std;

int main()
{
    int n, m;
    double p, r;
    cin >> n >> p >> r;
    r = 1 + r / 100;
    vector<vector<int>> sup(n);
    vector<int> ret(n, 0);
    for (int i = 0; i < n; ++i)
    {
        cin >> m;
        sup[i].resize(m);
        for (int j = 0; j < m; ++j)
            cin >> sup[i][j];
        if (m == 0) cin >> ret[i];
    }

    vector<int> crt{0}, tmp;
    double total = 0, rate = 1;
    while (!crt.empty())
    {
        int num = 0;
        for (auto &k: crt)
        {
            if (ret[k])
                num += ret[k];
            else
                tmp.insert(tmp.end(), sup[k].begin(), sup[k].end());
        }
        total += rate * num;
        rate *= r;
        crt = std::move(tmp);
        tmp = vector<int>();
    }

    total *= p;
    printf("%.1f", total);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值