POJ - 3673 Cow Multiplication

POJ - 3673


Description

Bessie is tired of multiplying pairs of numbers the usual way, so she invented her own style of multiplication. In her style, A*B is equal to the sum of all possible pairwise products between the digits of A and B. For example, the product 123*45 is equal to 1*4 + 1*5 + 2*4 + 2*5 + 3*4 + 3*5 = 54. Given two integers A and B (1 ≤ A, B ≤ 1,000,000,000), determine A*B in Bessie's style of multiplication.

Input

* Line 1: Two space-separated integers: A and B.

Output

* Line 1: A single line that is the A*B in Bessie's style of multiplication.

Sample Input

123 45

Sample Output

54

Source


/*
    Coder: Shawn_Xue
    Date: 2015.3.28
    Result: AC
    Description: POJ-3673  Cow Multiplication
*/
#include <iostream>

using namespace std;

int main()
{
    int a, b;

    while(cin >> a >> b)
    {
        int sum = 0;
        int tmp1 = 0, tmp2 = 0;
        while(a)
        {
            tmp1 = a % 10;
            int t = b;  //  把b保存起来
            while(t)
            {
                tmp2 = t % 10;
                sum = sum + tmp1*tmp2;
                t = t / 10;
            }
            a = a / 10;
        }
        cout << sum << endl;
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值