LA_3027_POJ_1962_CorporativeNetwork

8 篇文章 0 订阅
7 篇文章 0 订阅

3027 - Corporative Network

Time limit: 3.000 seconds

A very big corporation is developing its corporative network. In the beginning each of the N enterprises of the corporation, numerated from 1 to N, organized its own computing and telecommunication center. Soon, for amelioration of the services, the corporation started to collect some enterprises in clusters, each of them served by a single computing and telecommunication center as follow. The corporation chose one of the existing centers I (serving the cluster A) and one of the enterprises J in some cluster B (not necessarily the center) and link them with telecommunication line. The length of the line between the enterprises I and J is |I � J|(mod 1000). In such a way the two old clusters are joined in a new cluster, served by the center of the old cluster B. Unfortunately after each join the sum of the lengths of the lines linking an enterprise to its serving center could be changed and the end users would like to know what is the new length. Write a program to keep trace of the changes in the organization of the network that is able in each moment to answer the questions of the users.

Input 

Your program has to be ready to solve more than one test case. The first line of the input file will contains only the number T of the test cases. Each test will start with the number N of enterprises (5≤N≤20000). Then some number of lines (no more than 200000) will follow with one of the commands:

E I � asking the length of the path from the enterprise I to its serving center in the moment;
I I J � informing that the serving center I is linked to the enterprise J.

The test case finishes with a line containing the word O. The I commands are less than N.

Output 

The output should contain as many lines as the number of E commands in all test cases with a single number each � the asked sum of length of lines connecting the corresponding enterprise with its serving center.

Sample Input 

1
4
E 3
I 3 1
E 3
I 1 2
E 3
I 2 4
E 3
O

Sample Output 

0
2
3
5

一道并查集的题目

求得是某点到根的加权距离

注意每段距离要模1000但是总距离不用

另外我的想法是所有的求路径过程都在find路径压缩的同时完成

所以merge要连到题目要求的点而不是集合的根

#include <iostream>
#include <stdio.h>
#include <math.h>
using namespace std;

typedef long long LL;

const int MO=1000;
const int M=2e5+5;
int uf[M];
LL len[M];
char con[3];

LL abs(LL a)
{
    if(a>=0)
        return a;
    else
        return (-a);
}

int find(int i)
{
    //cout<<"f "<<i<<endl;
    if(i==uf[i])
        return i;
    int t=find(uf[i]);                      //先跑一遍之后的这样len[uf[i]]就有值了
    if(!len[i])
        len[i]=(len[uf[i]]+abs(i-uf[i])%MO);//从未连接过的点,或者是根节点
    else
        len[i]=(len[uf[i]]+len[i]);         //已经连接过的点
    //cout<<i<<" "<<len[i]<<endl;
    return uf[i]=t;
}

void merge(int i,int j)
{
    int t1=find(i);
    int t2=find(j);
    if(t1==t2)
        return;
    uf[t1]=j;                //注意接到的位置
}

int main()
{
    int t;
    int n;
    int cen,ent;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=1;i<=M;i++)
        {
            uf[i]=i;
            len[i]=0;
        }
        while(scanf("%s",con)!=EOF)
        {
            if(con[0]=='O')
                break;
            if(con[0]=='E')
            {
                scanf("%d",&ent);
                find(ent);
                printf("%lld\n",len[ent]);
            }
            if(con[0]=='I')
            {
                scanf("%d%d",&cen,&ent);
                merge(cen,ent);
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值