POJ_3080_BlueJeans

8 篇文章 0 订阅
5 篇文章 0 订阅

Blue Jeans
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14291 Accepted: 6361

Description

The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated. 

As an IBM researcher, you have been tasked with writing a program that will find commonalities amongst given snippets of DNA that can be correlated with individual survey information to identify new genetic markers. 

A DNA base sequence is noted by listing the nitrogen bases in the order in which they are found in the molecule. There are four bases: adenine (A), thymine (T), guanine (G), and cytosine (C). A 6-base DNA sequence could be represented as TAGACC. 

Given a set of DNA base sequences, determine the longest series of bases that occurs in all of the sequences.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of datasets. Each dataset consists of the following components:
  • A single positive integer m (2 <= m <= 10) indicating the number of base sequences in this dataset.
  • m lines each containing a single base sequence consisting of 60 bases.

Output

For each dataset in the input, output the longest base subsequence common to all of the given base sequences. If the longest common subsequence is less than three bases in length, display the string "no significant commonalities" instead. If multiple subsequences of the same longest length exist, output only the subsequence that comes first in alphabetical order.

Sample Input

3
2
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
3
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
3
CATCATCATCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
ACATCATCATAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AACATCATCATTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT

Sample Output

no significant commonalities
AGATAC
CATCATCAT

Source



这个题目也是一个求子串的题目

不过这个最长相同子串要求是连续的,而且长度大等3

再有就是需要在多个串中相同

60的长度

其实穷举第一个串的所有子串就可以了

其他的就用kmp来去跟别的字符串匹配就可以了

注意下这个题目要求输出字典序最小的序列


#include <iostream>
#include <stdio.h>
using namespace std;

const int M=65;
char s[10][M];
char s2[M];
char ans[M];
int nex[M];

void getnext(int m)
{
    int j=0,k=-1;
    nex[0]=-1;
    while(j<m)
    {
        if(k==-1||s2[k]==s2[j])
            nex[++j]=++k;
        else
            k=nex[k];
    }
}
int getp(int m,int n,int i)
{
    int j=0,k=0;
    while(j<n)
    {
        if(k==-1||s2[k]==s[i][j])
        {
            k++;j++;
        }
        else
            k=nex[k];
        if(k==m)
            return 1;
    }

    return 0;
}

int main()
{
    int t;
    int n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=0;i<n;i++)
            scanf("%s",s[i]);
        int ff=0;
        for(int l=60;l>2;l--)
        {
            ff=0;
            for(int st=0;st<=60-l;st++)
            {
                if(ff)
                {
                    int g=0;
                    for(int i=st;i<st+l;i++)  //判断是不是字典序更小的情况
                    {
                        if(s[0][i]-ans[i-st]<0)
                        {
                            g=1;
                            break;
                        }
                    }
                    if(!g)
                        break;
                }
                for(int i=st;i<st+l;i++)  //把需要比较的字符串拷贝出来
                    s2[i-st]=s[0][i];
                getnext(l);
                int f=1;
                for(int i=1;i<n;i++)
                {
                    //cout<<l<<" "<<st<<" i "<<i<<" "<<getp(l,60,i)<<endl;
                    if(!getp(l,60,i))
                    {
                        f=0;
                        break;
                    }
                }
                if(f)//当前串是可行解
                {
                    ff=1;
                    for(int i=0;i<l;i++)
                        ans[i]=s2[i];
                    ans[l]=0;
                }
            }
            if(ff)  //目前长度已经有解了
                break;
        }
        if(!ff)
            printf("no significant commonalities\n");
        else
            printf("%s\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值