LightOJ - 1138

You task is to find minimal natural number N, so that N! contains exactly Q zeroes on the trail in decimal notation. As you knowN! = 1*2*...*N. For example, 5! = 120, 120 contains one zero on the trail.


Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer Q (1 ≤ Q ≤ 108) in a line.

Output

For each case, print the case number and N. If no solution is found then print'impossible'.

Sample Input

3

1

2

5

Sample Output

Case 1: 5

Case 2: 10

Case 3: impossible


阶乘末尾包含多少个0,那么n以内的数的乘积就包含了多少个10,等价于包含了多少个5,例25的阶乘:25有两个5,20,15,10,5各包含1个5,共6个5,所以25以内有6个5,所以25!有6个0;

(要直接找10的个数是不行的,因为有很多的10是5的倍数乘以偶数形成的,实质上还是5的个数,并且5的倍数肯定比2的倍数少,只要有5就肯定有2让他两形成10)


给你一个零的个数n,用二分找m使得m!的0的个数为n个,找最小的m

#include <iostream>
#include <stdio.h>
#include <math.h>
#include <string.h>
#include <vector>
#include <algorithm>
#include <map>
using namespace std;
typedef long long LL;
const LL MAXN=((LL)1<<32);
#define fi first
#define se second

int main()
{
    int T,cas=0;
    scanf("%d",&T);
    while(T--)
    {
        int n;
        scanf("%d",&n);
        int left=1,right=5*n+10,mid=(left+right)/2;
        while(left<right)
        {
            mid=(left+right)/2;
            int z=0,h=mid;
            while(h)
            {
                z+=h/5;
                h/=5;
            }//m以内5的个数
            if(z<n)left=mid+1;
            else if(z>n)right=mid;
            else break;
        }
        mid=(mid/5)*5;
        int z=0,h=mid;
        while(h)
        {
            z+=h/5;
            h/=5;
        }
        printf("Case %d: ",++cas);
        if(z!=n)puts("impossible");
        else printf("%d\n",mid);
        //printf("%d\n",mid);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值