Prime Ring Problem_dfs

题目

 

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime. 

Note: the number of first circle should always be 1. 

 

Input

n (0 < n < 20). 

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order. 

You are to write a program that completes above process. 

Print a blank line after each case. 

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

 题目大意

输入n 然后要形成一个环,使得相邻的两个数和为素数 

 这些数必须是不重复的 从1到n的n个数4

要求按字典序输出所有的可能素数环序列

算法:DFS 

代码 

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int n,m,a[21];
char b[21];
int su(int x)
{  
	int i;
	if(x<2) return 0;
	for(i=2;i*i<=x;i++) if(x%i==0)break;
	if(i*i<=x) return 0;
	else return 1;
}
void dfs(int x)
{
	if(x==n && su(a[n-1]+1))//如果搜到最后一位 并且结果正确
	{ 
        cout<<"1";
        for(int j=1;j<n;j++)
        cout<<" "<<a[j];
        cout<<endl;
        return;
    }
	for(int j=2;j<=n;j++) //找数字 
	{
		if(b[j]==0 && su(a[x-1]+j))	//没被标记并且和环中前一个数之和为素数
		{  
			a[x]=j; 		  //放入环中 
			b[j]=1; 		 //标记 
			dfs(x+1);	    //继续深搜 
			b[j]=0;        //如果失败标记为零 
		}
	}
	return;	
}

int main()
{
	int i,s=1;
	while(cin>>n)
	{
		memset(b,0,sizeof(b)); 
		a[0]=1;//将1放入环中 
		b[1]=1;//标记1 
		cout<<"Case "<<s<<":"<<endl;
		dfs(1); 
		cout<<endl;
		s++;
	} 
	return 0;
}

 终止条件是安排完了所有数并且满足素数环的条件,然后输出

如果还没安排完,就从1-n中找数字(不能被标记-也就是每个数字只能使用一次),并且和素数环中前一个数字和为素数,name放上环中。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Cherish_lii

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值