HDOJ 1020 一次AC代码

/*****************************************************************************
Baichenjia 2013.8.25
HD1020 Encoding

Problem Description
Given a string containing only 'A' - 'Z', we could encode it using the following method:
1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.
2. If the length of the sub-string is 1, '1' should be ignored.

Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.

Output
For each test case, output the encoded string in a line.

Sample Input
2
ABC
ABBCCC

Sample Output
ABC
A2B3C
*****************************************************************************/

#include <iostream>
#include <string>
using namespace std;

int main()
{
     char str[10000];
     int n;
     int i,j;
    cin>>n;
while(n --)
{
char strtemp[10000];
memset(str,0,10000);
memset(strtemp,0,10000);
cin>>str;
for(i = 0,j = 1;;i ++)
{
strtemp[j] = str[i];
if((strtemp[j] == strtemp[j- 1]) || (strtemp[j - 1] == 0))
{
j ++;
}
else if((strtemp[j] != strtemp[j- 1]) || (i == strlen(str)))
{
if(j == 2)
cout<<strtemp[j - 1];
else
cout<<j - 1<<strtemp[j - 1];
if(i == strlen(str))
break;
i = i - 1;
j = 1;
memset(strtemp,0,10000);
}
else
{}
}
cout<<endl;
}
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值