Zball in Tina Town

Zball in Tina Town

Accepts: 356
Submissions: 2463
Time Limit: 3000/1500 MS (Java/Others)
Memory Limit: 262144/262144 K (Java/Others)
Problem Description

Tina Town is a friendly place. People there care about each other.

Tina has a ball called zball. Zball is magic. It grows larger every day. On the first day, it becomes111 time as large as its original size. On the second day,it will become 222 times as large as the size on the first day. On the n-th day,it will become nnn times as large as the size on the (n-1)-th day. Tina want to know its size on the (n-1)-th day modulo n.

Input

The first line of input contains an integer TTT, representing the number of cases.

The following TTT lines, each line contains an integer nnn, according to the description.T≤105,2≤n≤109 T \leq {10}^{5},2 \leq n \leq {10}^{9}T105,2n109

Output

For each test case, output an integer representing the answer.

Sample Input
2
3
10
Sample Output
2
0



这题就是求 (n1)!  mod  n

如果n为合数,显然答案为0.

如果n为素数,那么由威尔逊定理可得答案为n−1

注意有个trick为  n= 4.

它会每天变大。在第一天的时候,它会变大1倍。在第二天的时候,它会变大2倍。在第n天的时候,它会变大n倍。
zball原来的体积是1。Tina想知道,zball在第n1天时的体积对n取模是多大呢?

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>

using namespace std;

int n;
int main()
{
    int T;
    while(~scanf("%d",&T))
    {
        while(T--)
        {
            int flag=0;
            scanf("%d",&n);
            if(n==2)
                {printf("1\n");
                continue;
                }
            if(n==3)
                {printf("2\n");
                continue;
                }
            if(n==4)
            {printf("2\n");
             continue;
            }

            for(int i=2;i*i<=n;i++)
            {
                if(n%i==0)
                {
                    flag=1;
                    break;
                }
            }
            if(flag==0)
                printf("%d\n",n-1);
            else
                printf("0\n");
        }
    }
}

//用sqrt(n)会超时

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值