Zball in Tina Town HDU - 5391 (威尔逊定理)

Tina Town is a friendly place. People there care about each other.

Tina has a ball called zball. Zball is magic. It grows larger every day. On the first day, it becomes 1 time as large as its original size. On the second day,it will become 2 times as large as the size on the first day. On the n-th day,it will become nn times as large as the size on the (n-1)-th day. Tina want to know its size on the (n-1)-th day modulo n.
Input
The first line of input contains an integer T, representing the number of cases.

The following TT lines, each line contains an integer nn, according to the description.
T105,2n109
Output
For each test case, output an integer representing the answer.
Sample Input
2
3
10
Sample Output
2
0
除了4,需要特判一下:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<vector>
#define INF 0x7fffffff
#define N 100200
using namespace std;
bool prime[N];
vector<int> p;
void getPrime()
{
    for(int i=2;i<N;i++)
        if(!prime[i])
        {
            p.push_back(i);
            for(int j=i;j<N;j+=i)
                prime[j]=true;
        }
}
bool check(int x)
{
    for(int i=0;p[i]*p[i]<=x;i++)
        if(x%p[i]==0)
            return false;
    return true;
}
int main()
{
    getPrime();
    int t;
    scanf("%d",&t);
    int n;
    while(t--)
    {
        scanf("%d",&n);
        if(n==4)
        {
            printf("2\n");
            continue;
        }
        if(check(n))
            printf("%d\n",n-1);
        else
            printf("0\n");
    }
    return 0;   
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值