HDU 4764 博弈论

40 篇文章 0 订阅

Description

Tang and Jiang are good friends. To decide whose treat it is for dinner, they are playing a game. Specifically, Tang and Jiang will alternatively write numbers (integers) on a white board. Tang writes first, then Jiang, then again Tang, etc... Moreover, assuming that the number written in the previous round is X, the next person who plays should write a number Y such that 1 <= Y - X <= k. The person who writes a number no smaller than N first will lose the game. Note that in the first round, Tang can write a number only within range [1, k] (both inclusive). You can assume that Tang and Jiang will always be playing optimally, as they are both very smart students.
 

Input

There are multiple test cases. For each test case, there will be one line of input having two integers N (0 < N <= 10^8) and k (0 < k <= 100). Input terminates when both N and k are zero.
 

Output

For each case, print the winner's name in a single line.
 

Sample Input

     
     
1 1 30 3 10 2 0 0
 

Sample Output

     
     
Jiang Tang Jiang
 

题意:

Tang先选数,Jiang后选必须满足(1<=Y-X<=k),谁先到达大于等于n的数谁就输.

Tang的第一个数满足[1,k];


博弈论的水题一般比较好找规律,通过将数据从小到大的经行推一遍,很快就可找到规律.

n k

1 2 J   1 3 J

2 2 T   2 3 T

3 2 T   3 3 T

4 2 J   4  3 T

5 2 T   5 3  J

6 2 T  6 3 T

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<algorithm>

using namespace std;

int n,k,T;
double Min=10000.0;
double Max=0.0;
int main()
{
    while(~scanf("%d%d",&n,&k))
	{
		if(n==0&&k==0)break;
		if(n==1)
			printf("Jiang\n");
		else if(n%(k+1)==1)
			printf("Jiang\n");
		else
			printf("Tang\n");
	}

}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值