HDU 5461 沈阳网络赛

Largest Point

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 235    Accepted Submission(s): 112


Problem Description
Given the sequence A with n integers t1,t2,,tn . Given the integral coefficients a and b . The fact that select two elements ti and tj of A and ij to maximize the value of at2i+btj , becomes the largest point.
 

Input
An positive integer T , indicating there are T test cases.
For each test case, the first line contains three integers corresponding to n (2n5×106), a (0|a|106) and b (0|b|106) . The second line contains n integers t1,t2,,tn where 0|ti|106 for 1in .

The sum of n for all cases would not be larger than 5×106 .
 

Output
The output contains exactly T lines.
For each test case, you should output the maximum value of at2i+btj .
 

Sample Input
  
  
2 3 2 1 1 2 3 5 -1 0 -3 -3 0 3 3
 

Sample Output
  
  
Case #1: 20 Case #2: 0
 

Source
2015 ACM/ICPC Asia Regional Shenyang Online
题意,求公式的最大值, at2i+
 

Recommend

w

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
#include<cmath>
#define INF 0x3f3f3f3f
using namespace std;

struct node
{
    long long data;
    int num;
}arr[5000100],arr1[5000100];
int cmp(node p1,node p2)
{
    return p1.data<p2.data;
}
int main()
{
    int t,a,b,x,y;
    int n,m,i,j,k,flag,flag2,nnum=0;
    scanf("%d",&t);
    while(t--)
    {
        nnum++;
        scanf("%d%d%d",&n,&a,&b);
        long long ans=0;
        for(i=0; i<n; i++)
        {
            scanf("%lld",&arr[i].data);
            arr1[i].data=arr[i].data*arr[i].data;
            arr[i].num=arr1[i].num=i;
        }
        sort(arr,arr+n,cmp);
        sort(arr1,arr1+n,cmp);
        if(a>=0&&b>=0)
        {
           if(arr1[n-1].num==arr[n-1].num)
           {
               ans=max(a*arr1[n-1].data+b*arr[n-2].data,a*arr1[n-2].data+b*arr[n-1].data);
           }
           else
            ans=a*arr1[n-1].data+b*arr[n-1].data;
        }
        else if(a>=0&&b<=0)
        {
           if(arr1[n-1].num==arr[0].num)
           {
               ans=max(a*arr1[n-1].data+b*arr[1].data,a*arr1[n-2].data+b*arr[0].data);
           }
           else
            ans=a*arr1[n-1].data+b*arr[0].data;
        }
        else if(a<=0&&b>=0)
        {
            if(arr1[0].num==arr[n-1].num)
           {
               ans=max(a*arr1[0].data+b*arr[n-2].data,a*arr1[1].data+b*arr[n-1].data);
           }
           else
            ans=a*arr1[0].data+b*arr[n-1].data;
        }
        else if(a<=0&&b<=0)
        {
              if(arr1[0].num==arr[0].num)
           {
               ans=max(a*arr1[0].data+b*arr[1].data,a*arr1[1].data+b*arr[0].data);
           }
           else
            ans=a*arr1[0].data+b*arr[0].data;
        }
        printf("Case #%d: %lld\n",nnum,ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值