POJ 2524 Ubiquitous Religions(并查集 :擒贼先擒王原则)

                                               Ubiquitous Religions

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in. 

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

 

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

 

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

 

Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output

Case 1: 1
Case 2: 7

Hint

Huge input, scanf is recommended.

Source

Alberta Collegiate Programming Contest 200

题意描述:有n名学生,m次询问中每两个学生相信相同的宗教,求该大学学生所信仰的不同宗教的最大数量。

解题思路:运用并查集模板:擒贼先擒王原则。

代码如下:

#include<stdio.h>
struct node
{
	int u;
	int v;	
}map[100000];//询问学生对数的数组 
int f[50010];//用数组的下标来表示学生信仰的宗教

//这是找爹的递归函数,不停地去找爹,直到找到祖宗为止,其实就是找信仰同一个宗教的学生,擒贼先擒王原则 
int getf(int v)
{
	if(f[v]==v)
	return v; //找到祖宗 
	else
	{
		f[v]=getf(f[v]);//这里是路径压缩,每次在函数返回的时候,顺带把路上遇到的“BOSS”改为最后找到的祖宗编号,可以提高寻找速度。 
		return f[v];//找到祖宗 
	}
}
void merge(int u,int v)
{
	int t1,t2; 
	t1=getf(u);//t1表示u的大BOSS 
	t2=getf(v);//t2表示v的大BOSS 
	if(t1!=t2)//判断两个节点是否在同一个集合中,即是否为一个祖先 
	{
		f[t2]=t1;//靠左原则,左边变为右边的BOSS,即把右边的集合作为左边集合的子集和,经过路径压缩后,将f[v]的根的值也赋值为u的祖先f[t1] 
	}
	return ;
}
int main()
{
	int n,m,i,count,t=0;
	while(scanf("%d%d",&n,&m),n!=0||m!=0)
	{
		count=0;
		t++;
		for(i=1;i<=n;i++)
		f[i]=i;
		for(i=1;i<=m;i++)
		{
			scanf("%d%d",&map[i].u,&map[i].v);
			merge(map[i].u,map[i].v);//开始合并宗教 
		}
		//最后扫描有多少个宗教 
		for(i=1;i<=n;i++)
		{
			if(f[i]==i)
			count++;
		}
		printf("Case %d: %d\n",t,count);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值