POJ1094——Sorting It All Out

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three: 

Sorted sequence determined after xxx relations: yyy...y. 
Sorted sequence cannot be determined. 
Inconsistency found after xxx relations. 

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence. 

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.


拓扑排序第二弹~

#include <stdio.h>
#include <string.h>
int n,m,j,i;
int map[100][100],q,rudu[100],t[100];
int flag,flag1;
char a[100];
int ans[100];
int topo()
{
    int i,j,flag2=1,p,temp,k=0;
    memset(rudu,0,sizeof(rudu));//每次执行都回归0.
    for(i=0; i<n; i++)
        for(j=0; j<n; j++)
            if(map[i][j])
                rudu[j]++;//这种写法最通用、就不需要考虑重边不重边的问题了。
    for(i=0; i<n; i++)
        t[i]=rudu[i];//入度
    for(i=0; i<n; i++)
    {
        p=0;
        for(j=0; j<n; j++)
            if(t[j]==0)
            {
                p++;
                temp=j;
            }//记录入度为0的那个
        if(p==0&&p!=n)
            return 0;
        if(p>1)
            flag2=-1;
        ans[k++]=temp;
        t[temp]=-1;入度更新为-1,后边检测时不受影响
        for(j=0; j<n; j++)
            if(map[temp][j]==1)
                t[j]--;//相关联的入度减1
    }
    return flag2;
}
int main()
{
    while(scanf("%d%d",&n,&m)&&(m!=0||n!=0))
    {
        flag1=0;
        memset(map,0,sizeof(map));
        memset(rudu,0,sizeof(rudu));
        for(i=0; i<m; i++)
        {
            scanf("%s",a);
            map[a[0]-'A'][a[2]-'A']=1;
//            rudu[a[2]-'A']++;
            if(flag1==0)
                q=topo();
//                printf("###%d\n",q);
            if(q==1&&flag1==0)
            {
                printf("Sorted sequence determined after %d relations: ",i+1);
                for(j=0; j<n; j++)
                    printf("%c",ans[j]+'A');
                printf(".\n");
                flag1=1;
            }
            if(q==0&&flag1==0)
            {
                printf("Inconsistency found after %d relations.\n",i+1);
                flag1=1;
            }
        }
        if(flag1==0)
            printf("Sorted sequence cannot be determined.\n");
    }
    return 0;
}




                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值