PAT 1009. Product of Polynomials (25)

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6
 
思路:与多项式加法类似,乘法是遍历多项式每一非空项,与另外的多项式每一项相加,数值相乘。使用数值可以实现。

#include <iostream>
#include <iomanip>
using namespace std;

const int size = 1004; //数组元素量

int main()
{
	int na, nb;
	float a[size]= {0}, b[size] = {0}, c[size*2+1]={0};
	int count = 0, n;

	cin >> na;         //输入多项式A,B
	for (int i=0; i!=na; ++i) {
		cin >> n;
		cin >> a[n];
	}
	cin >> nb;
	for (int i=0; i!=nb; ++i) {
		cin >> n; 
		cin >> b[n];
	}

	for (int i=0; i!=size; ++i) 
		for (int j=0; j!=size; ++j) 
			if (a[i] != 0 || b[i] != 0)  //多项式乘法,项相加,数值相乘
		        c[i+j] += a[i] * b[j];

	for (int i=2*size; i>=0; --i) //统计多少项非0
		if (c[i] != 0)
            ++count;
	cout << count;

	for (int i=2*size; i>=0; --i) //输出格式控制
	{
		if (c[i] != 0)
			cout << " " << i << " " 
			<< setiosflags(ios::fixed) << setprecision(1) << c[i]; 
	}
	cout << endl;
	//system("pause");
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值