A - Primitive Roots----原根

72 篇文章 0 订阅
13 篇文章 0 订阅

We say that integer x, 0 < x < p, is a primitive root modulo odd prime p if and only if the set { (x  i mod p) | 1 <= i <= p-1 } is equal to { 1, ..., p-1 }. For example, the consecutive powers of 3 modulo 7 are 3, 2, 6, 4, 5, 1, and thus 3 is a primitive root modulo 7. 
Write a program which given any odd prime 3 <= p < 65536 outputs the number of primitive roots modulo p. 
Input
Each line of the input contains an odd prime numbers p. Input is terminated by the end-of-file seperator.
Output
For each p, print a single number that gives the number of primitive roots in a single line.
Sample Input
23
31
79
Sample Output
10
8
24

题目链接:https://cn.vjudge.net/contest/157463#problem/A


原根问题,这一类题有求最小原根,原根的个数,具体怎么推得我忘记了,好像有什么欧拉函数?积性函数?GCD?我只记住结论了。


代码:

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
int dp[100000];
int prime[100000];
bool vis[100000];
void Init(){
    dp[1]=1;
    int top=0;
    for(int i=2;i<100000;i++){
        if(!vis[i]){
            prime[++top]=i;
            dp[i]=i-1;
        }
        for(int j=1;j<=top;j++){
            if(i*prime[j]>=100000)
                break;
            vis[i*prime[j]]=1;
            if(i%prime[j]==0){
                dp[i*prime[j]]=dp[i]*prime[j];//只记住了这个结论
                break;
            }
            else{
                dp[i*prime[j]]=dp[i]*(prime[j]-1);
                //cout<<i*prime[j]<<dp[i*prime[j]]<<endl;
            }
        }
    }
}
int main(){
    Init();
    int n;
    while(~scanf("%d",&n)){
        printf("%d\n",dp[n-1]);
    }
    return 0;
}


刚才上网上收了几个大牛的博客,51nod上有个题,1135,是求最小原根的

http://blog.csdn.net/huayunhualuo/article/details/51095717

http://blog.csdn.net/corncsd/article/details/33414871?locationNum=2&fps=1

http://blog.csdn.net/wahaha1_/article/details/8078753

http://blog.csdn.net/tsaid/article/details/7296307

这个是51nod的最小原根

http://blog.csdn.net/u013486414/article/details/47781857



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值