J - Slim Span 思维+并查集

J - Slim Span

  POJ - 3522 

Given an undirected weighted graph G, you should find one of spanning trees specified as follows.

The graph G is an ordered pair (VE), where V is a set of vertices {v1v2, …, vn} and E is a set of undirected edges {e1e2, …, em}. Each edge e ∈ E has its weightw(e).

A spanning tree T is a tree (a connected subgraph without cycles) which connects all the n vertices with n − 1 edges. The slimness of a spanning tree T is defined as the difference between the largest weight and the smallest weight among the n − 1 edges of T.

 
Figure 5: A graph  G and the weights of the edges

For example, a graph G in Figure 5(a) has four vertices {v1v2v3v4} and five undirected edges {e1e2e3e4e5}. The weights of the edges are w(e1) = 3, w(e2) = 5, w(e3) = 6, w(e4) = 6, w(e5) = 7 as shown in Figure 5(b).

 
Figure 6: Examples of the spanning trees of  G

There are several spanning trees for G. Four of them are depicted in Figure 6(a)~(d). The spanning tree Ta in Figure 6(a) has three edges whose weights are 3, 6 and 7. The largest weight is 7 and the smallest weight is 3 so that the slimness of the tree Ta is 4. The slimnesses of spanning trees TbTc and Td shown in Figure 6(b), (c) and (d) are 3, 2 and 1, respectively. You can easily see the slimness of any other spanning tree is greater than or equal to 1, thus the spanning tree Td in Figure 6(d) is one of the slimmest spanning trees whose slimness is 1.

Your job is to write a program that computes the smallest slimness.

Input

The input consists of multiple datasets, followed by a line containing two zeros separated by a space. Each dataset has the following format.

nm 
a1b1w1
  
ambmwm

Every input item in a dataset is a non-negative integer. Items in a line are separated by a space. n is the number of the vertices and m the number of the edges. You can assume 2 ≤ n ≤ 100 and 0 ≤ m ≤ n(n − 1)/2. ak and bk (k = 1, …, m) are positive integers less than or equal to n, which represent the two vertices vak andvbk connected by the kth edge ekwk is a positive integer less than or equal to 10000, which indicates the weight of ek. You can assume that the graph G = (VE) is simple, that is, there are no self-loops (that connect the same vertex) nor parallel edges (that are two or more edges whose both ends are the same two vertices).

Output

For each dataset, if the graph has spanning trees, the smallest slimness among them should be printed. Otherwise, −1 should be printed. An output should not contain extra characters.

Sample Input
4 5
1 2 3
1 3 5
1 4 6
2 4 6
3 4 7
4 6
1 2 10
1 3 100
1 4 90
2 3 20
2 4 80
3 4 40
2 1
1 2 1
3 0
3 1
1 2 1
3 3
1 2 2
2 3 5
1 3 6
5 10
1 2 110
1 3 120
1 4 130
1 5 120
2 3 110
2 4 120
2 5 130
3 4 120
3 5 110
4 5 120
5 10
1 2 9384
1 3 887
1 4 2778
1 5 6916
2 3 7794
2 4 8336
2 5 5387
3 4 493
3 5 6650
4 5 1422
5 8
1 2 1
2 3 100
3 4 100
4 5 100
1 5 50
2 5 50
3 5 50
4 1 150
0 0
Sample Output
1
20
0
-1
-1
1
0
1686
50

题目链接:https://cn.vjudge.net/contest/161625#problem/J


题目的意思就是说给你一个图,让你用n-1条边组成一个子图,然后用子图中的最大边-最小边,求最小的可能。

比赛的时候想优化一下,结果手残。。。

边数不多,我们暴力就好,对于选哪条边来说,我们可以使用并查集来判断。

代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#define inf 0x3f3f3f3f
using namespace std;
struct node{
    int u,v,w;
}xin[6000];
bool cmp(struct node a,struct node b){
    return a.w>b.w;
}
int pre[101];
int Find(int x){
    return x==pre[x]?x:Find(pre[x]);
}
void mix(int x,int y){
    int xx=Find(x),yy=Find(y);
    if(xx!=yy){
        if(xx>yy){
            pre[xx]=yy;
        }
        else{
            pre[yy]=xx;
        }
    }
}
int main(){
    int n,m;
    while(~scanf("%d%d",&n,&m)){
        if(n+m==0)
            break;
        for(int i=0;i<m;i++){
            int u,v,w;
            scanf("%d%d%d",&u,&v,&w);
            xin[i].u=u;
            xin[i].v=v;
            xin[i].w=w;
        }
        sort(xin,xin+m,cmp);
        int ans=inf;
        for(int i=0;i<m;i++){
            for(int j=0;j<=n;j++){
                pre[j]=j;
            }
            int sum=0;
            for(int j=i;j<m;j++){
                int u=xin[j].u;
                int v=xin[j].v;
                int x=Find(u);
                int y=Find(v);
                if(x!=y){
                    sum++;
                    mix(x,y);
                }
                if(sum==n-1){
                    ans=min(ans,xin[i].w-xin[j].w);
                }
            }
        }
        if(ans==inf){
            printf("-1\n");
            continue;
        }
        printf("%d\n",ans);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值