poj 迷宫问题(路径记录)(DFS,BFS)

46 篇文章 0 订阅
迷宫问题

Description

定义一个二维数组:  
int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)
代码1(DFS):
#include<stdio.h>
#include<string.h>
#include<stack>
#define INF 0x3f3f3f3f
using namespace std;
int a[5][5],ans=INF,k;
struct node
{
    int x,y;
} b[100];
void mycopy(stack<node> a)//路径反转
{
    for(k=0; !a.empty(); k++)
    {
        b[k]=a.top();
        a.pop();
    }
}
int to[4][2]= {0,1,0,-1,1,0,-1,0};
stack<node>s;//存储路径
void dfs(int x,int y,int step)
{
    node now;
    now.x=x,now.y=y;
    s.push(now);
    if(x==4&&y==4)
    {
        if(step<ans)//找寻最短路径
        {
            ans=step;
            mycopy(s);
        }
    }
    for(int i=0; i<4; i++)
    {
        int m=now.x+to[i][0],n=now.y+to[i][1];
        if(m>=0&&m<5&&n>=0&&n<5&&!a[m][n])
        {
            a[m][n]=1;
            dfs(m,n,step+1);
            a[m][n]=0;//还原
        }
    }
    s.pop();
}
int main()
{
    int i,j;
    for(i=0; i<5; i++)
        for(j=0; j<5; j++)
            scanf("%d",&a[i][j]);
    dfs(0,0,0);
    for(i=k-1; i>=0; i--)//输出
        printf("(%d, %d)\n",b[i].x,b[i].y);
    return 0;
}

代码2(BFS):
#include<stdio.h>
int a[5][5],head=0,tail=1;
struct node
{
    int x,y,front;//front记录每一步的位置
} b[100];
void print(int i)
{
    if(b[i].front!=-1)
    {
        print(b[i].front);
        printf("(%d, %d)\n",b[i].x,b[i].y);
    }
}
int to[4][2]= {0,1,0,-1,1,0,-1,0};
void bfs(int x,int y)
{
    b[head].x=x,b[head].y=y;
    b[head].front=-1;
    a[x][y]=1;
    while(head<tail)
    {
        for(int i=0; i<4; i++)
        {
            int m=b[head].x+to[i][0],n=b[head].y+to[i][1];
            if(m>=0&&m<5&&n>=0&&n<5&&!a[m][n])
            {
                a[m][n]=1;
                b[tail].x=m;
                b[tail].y=n;
                b[tail].front=head;//记录当前位置的上一步是哪个位置
                tail++;
            }
            if(m==4&&n==4)
                print(head);
        }
        head++;
    }
}
int main()
{
    int i,j;
    for(i=0; i<5; i++)
        for(j=0; j<5; j++)
            scanf("%d",&a[i][j]);
    printf("(0, 0)\n");
    bfs(0,0);
    printf("(4, 4)\n");
    return 0;
}
ps:BFS主要是给每一步都做上一个位置标记,让每一步都记录上一步的位置,也就是记录这一步是从哪一步过来的
  • 1
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
根据提供的引用内容,可以得知这是一道关于迷宫问题的题目,需要使用Java语言进行编写。具体来说,这道题目需要实现一个迷宫的搜索算法,找到从起点到终点的最短路径。可以使用广度优先搜索或者深度优先搜索算法来解决这个问题。 下面是一个使用广度优先搜索算法的Java代码示例: ```java import java.util.*; public class Main { static int[][] maze = new int[5][5]; // 迷宫地图 static int[][] dir = {{0, 1}, {0, -1}, {1, 0}, {-1, 0}}; // 方向数组 static boolean[][] vis = new boolean[5][5]; // 标记数组 static int[][] pre = new int[5][5]; // 记录路径 public static void main(String[] args) { Scanner sc = new Scanner(System.in); for (int i = 0; i < 5; i++) { for (int j = 0; j < 5; j++) { maze[i][j] = sc.nextInt(); } } bfs(0, 0); Stack<Integer> stack = new Stack<>(); int x = 4, y = 4; while (x != 0 || y != 0) { stack.push(x * 5 + y); int t = pre[x][y]; x = t / 5; y = t % 5; } stack.push(0); while (!stack.empty()) { System.out.print(stack.pop() + " "); } } static void bfs(int x, int y) { Queue<Integer> qx = new LinkedList<>(); Queue<Integer> qy = new LinkedList<>(); qx.offer(x); qy.offer(y); vis[x][y] = true; while (!qx.isEmpty()) { int tx = qx.poll(); int ty = qy.poll(); if (tx == 4 && ty == 4) { return; } for (int i = 0; i < 4; i++) { int nx = tx + dir[i][0]; int ny = ty + dir[i][1]; if (nx >= 0 && nx < 5 && ny >= 0 && ny < 5 && maze[nx][ny] == 0 && !vis[nx][ny]) { vis[nx][ny] = true; pre[nx][ny] = tx * 5 + ty; qx.offer(nx); qy.offer(ny); } } } } } ``` 该代码使用了广度优先搜索算法,首先读入迷宫地图,然后从起点开始进行搜索,直到找到终点为止。在搜索的过程中,使用标记数组记录已经访问过的位置,使用路径数组记录路径。最后,使用栈来输出路径

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值