poj A Knight's Journey(DFS)(字典序)

46 篇文章 0 订阅
A Knight's Journey

Description

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
ps:
弄了一下午,坑死在了字典序上0.0 敲打
这一题的字典序:就是先按列排序,较小的在前。然后按行排序,也是较小的在前。
int diri[8]={-1,1,-2,2,-2,2,-1,1};
int dirj[8]={-2,-2,-1,-1,1,1,2,2};
也就是(借鉴大神的图)


另外,国际象棋的棋盘:行为数字p,列为字母q


代码:
#include<stdio.h>
#include<string.h>
int n,m,flag;
int vis[30][30];
int to[8][2]= {{-1,-2},{1,-2},{-2,-1},{2,-1},{-2,1},{2,1},{-1,2},{1,2}};//方向
struct node
{
    int x,y;
} w[30];
int judge(int x,int y)
{
    if(x>0&&x<=n&&y>0&&y<=m&&!vis[x][y])
        return 1;
    return 0;
}
void dfs(int x,int y,int step)
{
    w[step].x=x,w[step].y=y;
    if(step==n*m)//如果已经遍历了所有的点
    {
        for(int i=1; i<=step; i++)
            printf("%c%d",w[i].y-1+'A',w[i].x);
        printf("\n");
        flag=1;//标记已经找到答案
    }
    if(flag)
        return ;
    for(int i=0; i<8; i++)
    {
        int xx=x+to[i][0];
        int yy=y+to[i][1];
        if(judge(xx,yy))
        {
            vis[xx][yy]=1;
            dfs(xx,yy,step+1);
            vis[xx][yy]=0;
        }
    }
    if(flag)
        return ;
}
int main()
{
    int t,cont=0;
    scanf("%d",&t);
    while(++cont<=t)
    {
        memset(vis,0,sizeof(vis));
        flag=0;
        scanf("%d%d",&n,&m);
        printf("Scenario #%d:\n",cont);
        if(n>8||m>8)
            printf("impossible\n");
        else
        {
            vis[1][1]=1;
            dfs(1,1,1);
            if(!flag)
                printf("impossible\n");
        }
        printf("\n");
    }
    return 0;
}



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值