搜索练习题B-02

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
题目大意就是给出棋盘长宽,求是否能遍历棋盘,如果能要输出遍历顺序,输出按照字典序最小的;
看到题时第一反应无非是广搜,但提交数次都没过后发现字典序的问题,才发现dx与dy要按一定顺序(看代码)才能保证字典序,这样才正确,细节看代码吧。
#include<iostream>
#include<string>
#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<math.h>
using namespace std;
int vis[27][27],p,q,o=1,ok=0,dy[8]={-2,-2,-1,-1,1,1,2,2},dx[8]={-1,1,-2,2,-2,2,-1,1};//顺序必须这样从下到上,从左到右。
struct node
{
    int x,y;//位置
}an[200];
void print()//打印
{
    char a;
    for(int i=0;i<o;i++)
    {
        a='A'-1+an[i].y;
        cout<<a<<an[i].x;
    }
}
void solve(int x,int y)
{
    if(ok) return ;//结束
    if(o==p*q) {ok=1;print();return ;}//全部遍历完,ok=1,结束
    for(int i=0;i<8;i++)
    {
        if(x+dx[i]>0&&x+dx[i]<=p&&y+dy[i]>0&&y+dy[i]<=q)//判断棋盘范围之内
        {
            if(!vis[x+dx[i]][y+dy[i]])
            {
                vis[x+dx[i]][y+dy[i]]=1;//标志访问过
                an[o].x=x+dx[i];an[o].y=y+dy[i];o++;
                solve(x+dx[i],y+dy[i]);
                vis[x+dx[i]][y+dy[i]]=0;o--;//不能忘记恢复
            }
        }
    }
    return ;//如果无法遍历,也要结束,这步不能少
}
int main()
{
    int z=1,n;
    cin>>n;
    while(n--)
    {
        cin>>p>>q;
        vis[1][1]=1;
        an[0].x=1;an[0].y=1;
        cout<<"Scenario #"<<z<<":"<<endl;z++;
        solve(1,1);
        if(!ok) cout<<"impossible";
        cout<<endl;
        if(n) cout<<endl;ok=0;o=1;
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值