hdu 1525 Euclid's Game(博弈——找规律)

Euclid’s Game

Problem Description

Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7):

25 7
11 7
4 7
4 3
1 3
1 0

an Stan wins.

Input

The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.

Output

For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.

Sample Input

34 12
15 24
0 0

Sample Output

Stan wins
Ollie wins



题意:给出两个数a和b,两个人轮流操作,每次操作都可以让较大的数减去较小的数的整数倍,当其中有个数变为0时则获胜,问最终谁能获胜

思路:没给数据范围,用SG函数写了下直接RE了…(估计数很大)

那就只有找规律了

令n为较小的数,m为较大的数,可以发现:
当m%n=0时,先手必胜

当m>=2n时,如果(m%n,m)为必胜态,先手可以先将局势变为(m%n+n,n),则后手只能将局势变为(m%n,n);如果(m%n,n)为必败态,先手可以直接将局势变为(m%n,n)。因此,不论(m%n,n)为什么态,先手都必胜

当2n>m>n时,那就是一步一步走下去,直到出现m%n=0||m>=2n结束

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m),n+m)
    {
        if(n>m)
            swap(n,m);
        if(m>=2*n||(m%n==0))
            printf("Stan wins\n");
        else
        {
            int flag=1;
            while(1)
            {
                m-=n;
                swap(n,m);
                flag^=1;
                if(m>=2*n||(m%n==0))
                    break;
            }
            if(flag)
                printf("Stan wins\n");
            else
                printf("Ollie wins\n");
        }
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值