HDOJ-----1005---Number Sequence暴力枚举

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 158460    Accepted Submission(s): 38811


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5
刚开始把%7习惯性看成了%1e9+7,心累,因为是%7所以f(x)只有数字0-6,共有49种组合,必然存在周期

49次循环之内一定可以找出周期

#include<cstdio>
#include<iostream>
#include<cmath>
#include<cstring>
#include<string>
#include<algorithm>
#include<map>
#include<queue>
#include<vector>
#define PI acos(-1.0)
#define INF 0x3f3f3f3f
#define CL(a, b) memset(a, b, sizeof(a))
using namespace std;
typedef long long LL;
const int maxn = 5e5+10;
const int MOD = 1e9+7; 
int cnt[55];
int main(){  
    int a, b, n, ans, kcase = 1;
    cnt[1] = cnt[2] = 1;
    while(scanf("%d%d%d", &a, &b, &n) && (a || b || n)){
    	if(n < 3){
    		printf("1\n");
    		continue;
		}
    	bool flag = false;
    	ans = 0;
    	for(int i = 3; i <= n; i++){
    		cnt[i] = (a*cnt[i-1] + b*cnt[i-2]) % 7;
    		for(int j = 2; j < i; j++){
    			if(cnt[i] == cnt[j] && cnt[i-1] == cnt[j-1]){
    				flag = true;
    				ans = j+((n-i) % (i-j));
    				break;
				}
			}
			if(flag) break;
		}
		if(!ans) ans = n;
		printf("%d\n", cnt[ans]);
	}
    return 0;  
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值