HDOJ-----4135Co-prime容斥原理三种实现

Co-prime

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4374    Accepted Submission(s): 1724


Problem Description
Given a number N, you are asked to count the number of integers between A and B inclusive which are relatively prime to N.
Two integers are said to be co-prime or relatively prime if they have no common positive divisors other than 1 or, equivalently, if their greatest common divisor is 1. The number 1 is relatively prime to every integer.
 

Input
The first line on input contains T (0 < T <= 100) the number of test cases, each of the next T lines contains three integers A, B, N where (1 <= A <= B <= 10 15) and (1 <=N <= 10 9).
 

Output
For each test case, print the number of integers between A and B inclusive which are relatively prime to N. Follow the output format below.
 

Sample Input
  
  
2 1 10 2 3 15 5
 

Sample Output
 
 
Case #1: 5 Case #2: 10
Hint
In the first test case, the five integers in range [1,10] which are relatively prime to 2 are {1,3,5,7,9}.

可参考容斥原理那一篇博客

#include<cstdio>
#include<iostream>
#include<cmath>
#include<cstring>
#include<string>
#include<algorithm>
#include<map>
#include<set> 
#include<stack>
#include<queue>
#include<vector>
#include<functional>
#define PI acos(-1.0)
#define INF 0x3f3f3f3f
#define CL(a, b) memset(a, b, sizeof(a))
using namespace std;
typedef long long LL;
const int maxn = 1e5+10;
const int MOD = 1e9+7;
LL ans, num[maxn], fac[maxn];
void get_fac(int n){
	ans = 0;
	for(int i = 2; i*i <= n; i++){
		if(n%i == 0){
			num[ans++] = i;
			while(n%i == 0) n /= i;
		}
	}
	if(n > 1) num[ans++] = n;
}
/*二进制实现 
LL exc(LL A){
	LL cnt = 0;
	for(LL i = 1; i < LL(1<<ans); i++){
		LL bit, cur;
		bit = 0; cur = 1;
		for(LL j = 0; j < ans; j++){
			if(LL(1<<j) & i){
				bit++;
				cur *= num[j];
			}
		}
		cur = A/cur;
		if(bit&1) cnt += cur;
		else cnt -= cur; 
	}
	return A-cnt;
}
*/
/*数组实现 
LL exc(LL A){
	LL cnt, t, k;
	cnt = t = 0;
	for(int i = 0; i < ans; i++){
		k = t;
		fac[t++] = num[i];
		for(int j = 0; j < k; j++) fac[t++] = -1*fac[j]*num[i];
	}
	for(LL i = 0; i < t; i++) cnt += A/fac[i];
	return A-cnt;
}
*/
//递归实现 
LL exc(LL n, int i){
	LL cnt = 0;
	for(; i < ans; i++) cnt += n/num[i] - exc(n/num[i], i+1);
	return cnt;
} 
int main(){
	int n, t, kcase = 1;
	LL a, b;
	scanf("%d", &t);
	while(t--){
		scanf("%lld%lld%d", &a, &b, &n);
		get_fac(n);
		//printf("Case #%d: %lld\n", kcase++, exc(b) - exc(a-1));
		printf("Case #%d: %lld\n", kcase++, b-exc(b, 0) - (a-1-exc(a-1, 0)));
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值