poj1703——Find them, Catch them

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

  1. D [a] [b]
    where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

  2. A [a] [b]
    where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message “A [a] [b]” in each case, your program should give the judgment based on the information got before. The answers might be one of “In the same gang.”, “In different gangs.” and “Not sure yet.”

Sample Input
1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output
Not sure yet.
In different gangs.
In the same gang.

这道题有点考验逻辑能力。将数组长度设为人数的两倍,k处于一个帮派时k+n也得处于另一个帮派。具体的步骤写在代码注释中,这样更好解释

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
const int maxn=100010;
int f[maxn+maxn];    //k所属的帮派为f[k],另一帮派为f[k+n],后面要得出k所属帮派结论至少需要这两个元素
int find(int x)   //寻找x所属帮派
{
    if(f[x]<0)    //即f[x]==-1,代表该元素所属帮派不明确,只能用自己代替
        return x;
    return f[x]=find(f[x]);
}
int main()
{
    int t,n,m,i,a,b;
    char s[5];
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        memset(f,-1,sizeof(f)); //最开始所有人都不知道属于哪个帮派,所以用-1代替
        for(i=0;i<m;++i)
        {
            scanf("%s%d%d",s,&a,&b);
            if(s[0]=='A')
            {
                //a不属于b的帮派也不属于b不属于的帮派,所以结果不知道
                if(find(a)!=find(b)&&find(a)!=find(b+n))
                    printf("Not sure yet.\n");
                //a,b所属帮派相同
                else if(find(a)==find(b))
                    printf("In the same gang.\n");
                //最后一种情况只能是不同
                else
                    printf("In different gangs.\n");
            }
            else   //要a,b不属于同一个帮派,a不能属于b所属的帮派,还要属于b不属于的帮派,即两个条件都要满足
            {
                //如果a所属的帮派不为b的另一帮派,则a所属帮派为b的另一帮派,b所属帮派为a的另一帮派
                if(find(a)!=find(b+n))
                {
                    f[find(a)]=find(b+n);
                    f[find(b)]=find(a+n);
                }
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值