poj2488——A Knight's Journey(dfs)

Description

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?
这里写图片描述
Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, … , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, …
Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.
Sample Input

3
1 1
2 3
4 3
Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

给出p*q的棋盘,求骑士走过所有位置的路线
简单的dfs,唯一注意的就是答案要求按字典序输出,因此遍历顺序也要是字典序
后台的数据应该很小,我9*9就很慢了,一度优化了很久。。。虽然还是A了

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <map>
#include <cmath>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 100005
#define Mod 10001
using namespace std;
int p,q,flag;
int vis[30][30];
int dx[8]={-1,1,-2,2,-2,2,-1,1};
int dy[8]={-2,-2,-1,-1,1,1,2,2};
struct Node
{
    int p[900],top;
    char q[900];
};
Node ans;
void dfs(int x1,int y1,int step)
{
    if(step==p*q)
    {
        for(int i=0;i<ans.top;++i)
            cout<<ans.q[i]<<ans.p[i];
        cout<<endl;
        flag=1;
        return;
    }
    for(int i=0;i<8;++i)
    {
        int x=x1+dx[i];
        int y=y1+dy[i];
        if(x<0||x>=p||y<0||y>=q||vis[x][y])
            continue;
        else
        {
            vis[x][y]=1;
            ans.p[ans.top]=x+1;
            ans.q[ans.top]=char(y+'A');
            ans.top++;
            dfs(x,y,step+1);
            ans.top--;
            vis[x][y]=0;
            if(flag)
                return;
        }
    }
    if(flag)
        return;
}
int main()
{
    int t;
    scanf("%d",&t);
    for(int i=1;i<=t;++i)
    {
        flag=0;
        memset(vis,0,sizeof(vis));
        ans.top=0;
        scanf("%d%d",&p,&q);
        vis[0][0]=1;
        ans.p[ans.top]=1;
        ans.q[ans.top]=char(0+'A');
        ans.top++;
        if(i!=1)
            printf("\n");
        printf("Scenario #%d:\n",i);
        dfs(0,0,1);
        if(!flag)
            printf("impossible\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值