hdoj 2266 How Many Equations Can You Find (dfs)

How Many Equations Can You Find

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 908    Accepted Submission(s): 604


Problem Description
Now give you an string which only contains 0, 1 ,2 ,3 ,4 ,5 ,6 ,7 ,8 ,9.You are asked to add the sign ‘+’ or ’-’ between the characters. Just like give you a string “12345”, you can work out a string “123+4-5”. Now give you an integer N, please tell me how many ways can you find to make the result of the string equal to N .You can only choose at most one sign between two adjacent characters.
 

Input
Each case contains a string s and a number N . You may be sure the length of the string will not exceed 12 and the absolute value of N will not exceed 999999999999.
 

Output
The output contains one line for each data set : the number of ways you can find to make the equation.
 

Sample Input
  
  
123456789 3 21 1
 

Sample Output
  
  
18 1
 

题意:一个数字字符串,可以在任意位置加‘+’或‘-’,使结果等于n,问有多少中方法

思路:每个数字前有三种情况:不加符号;加‘+’号;加‘-’号。

奇妙的dfs,奇妙的递归,看了大神代码,觉得搜索很有用,巧妙

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
char s[30];
long long n,ans;
int len;
void dfs(long long sum,long long sum1,int pos,int op)
{
    if(pos==len )
    {
        if(n==sum+sum1*op)
            ans++;
        return ;
    }
    dfs(sum,sum1*10+s[pos]-'0',pos+1,op);//之间不加符号,保留原符号
    dfs(sum+sum1*op,s[pos]-'0',pos+1,1);//下一个数前加一个 加号
    dfs(sum+sum1*op,s[pos]-'0',pos+1,-1);//下一个数前加一个 减号
}
int main()
{
    while(~scanf("%s %lld",s,&n))
    {
        len=strlen(s);
        ans=0;
        dfs(0,s[0]-'0',1,1);
        printf("%lld\n",ans);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值