hdu2602Bone Collector(动态规划)

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 41023    Accepted Submission(s): 17078


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input
  
  
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
  
  
14
题目大意:搜集骨头的老头有个容量 V 的背包,已知有N个骨头,每个骨头的价值和体积分别为 v[i]和w[i].问老头搜集的骨头最大价值数是多少?
解题思路:01背包问题,直接用01背包解决。
代码:
#include<stdio.h>
#include<string.h>
int max(int x,int y)
{
	if(x>y)
	 return x;
	else
	 return y;
}
struct node{
	int v,w;
}a[1010];
int dp[1010][1010];
int main()
{
	int t;
	int V,N,i,j;
	scanf("%d",&t);
	while(t--)
	{
		memset(a,0,sizeof(a));
		scanf("%d%d",&N,&V);
		for(i=0;i<N;i++)
		  scanf("%d",&a[i].v);
		for(i=0;i<N;i++)
		  scanf("%d",&a[i].w);
		memset(dp,0,sizeof(dp));
		for(i=N-1;i>=0;i--)
		{
			for(j=0;j<=V;j++)
			{
				if(j<a[i].w)
				 dp[i][j]=dp[i+1][j];
				else
				 dp[i][j]=max(dp[i+1][j],dp[i+1][j-a[i].w]+a[i].v);
			}
		}
	printf("%d\n",dp[0][V]);
	}
return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bokzmm

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值