poj2229susmets


Online JudgeProblem SetAuthorsOnline ContestsUser
Web Board
Home Page
F.A.Qs
Statistical Charts
Problems
Submit Problem
Online Status
Prob.ID:
Register
Update your info
Authors ranklist
Current Contest
Past Contests
Scheduled Contests
Award Contest
zmmqq      Log Out
Mail:3(3)
Login Log      Archive
Language:

Time Limit: 2000MS Memory Limit: 200000K
Total Submissions: 15118 Accepted: 6022

Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6

Source




题目大意:求一个数的划分数?且划分这些数的数字都是2的幂数;如2^0=1,  2^1=2  ,2^2=4;

解题思路:首先,我们看几个数的划分数:

3:
3=1+1+1;

3=1+2;

4:

4=1+1+1+1;

4=1+1+2;

4=2+2;

4=4;

5:

5=1+1+1+1+1;

5=1+1+1+2;

5=1+2+2;

5=1+4;

6:

6=1+1+1+1+1+1;

6=1+1+1+1+2;

6=1+1+2+2;

6=1+1+4;

6=2+2+2;

6=2+4;

可以发现:若n为奇数时,其划分数等于它上一个数的划分数,当n为偶数时,其划分数为其上一个数的划分数,再加上它一半的数的划分数。

如果设dp[i]表示 i 按照题意的划分数。如果i为偶数,那么所有i-1的划分都加上1之后,就是i的划分的一部分,同理,dp[i/2]的划分就是i的另一部分划分。

两者之和就是当i为偶数是的划分数,i为奇数时;i的划分与i-1的划分相同。

所以有动态转移方程:

i为偶数: dp[i] = dp[i-1] + dp[i/2];

i为奇数:dp[i] = dp[i-1] ;

AC代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[10000010];
int main()
{
    int n,i,j,k;
    dp[1]=1;dp[2]=2;
	for(i=3;i<=1000000;i++)
	{
		if(i%2==0)
		{
			dp[i]=dp[i-2]+dp[i/2];
			dp[i]%=1000000000;
		}
		else
		 dp[i]=dp[i-1];
	}
	scanf("%d",&n);
	printf("%d\n",dp[n]);
    return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bokzmm

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值