poj2393Yogurt factory(贪心-坑)

18 篇文章 0 订阅
Yogurt factory
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8108 Accepted: 4151

Description

The cows have purchased a yogurt factory that makes world-famous Yucky Yogurt. Over the next N (1 <= N <= 10,000) weeks, the price of milk and labor will fluctuate weekly such that it will cost the company C_i (1 <= C_i <= 5,000) cents to produce one unit of yogurt in week i. Yucky's factory, being well-designed, can produce arbitrarily many units of yogurt each week. 

Yucky Yogurt owns a warehouse that can store unused yogurt at a constant fee of S (1 <= S <= 100) cents per unit of yogurt per week. Fortuitously, yogurt does not spoil. Yucky Yogurt's warehouse is enormous, so it can hold arbitrarily many units of yogurt. 

Yucky wants to find a way to make weekly deliveries of Y_i (0 <= Y_i <= 10,000) units of yogurt to its clientele (Y_i is the delivery quantity in week i). Help Yucky minimize its costs over the entire N-week period. Yogurt produced in week i, as well as any yogurt already in storage, can be used to meet Yucky's demand for that week.

Input

* Line 1: Two space-separated integers, N and S. 

* Lines 2..N+1: Line i+1 contains two space-separated integers: C_i and Y_i.

Output

* Line 1: Line 1 contains a single integer: the minimum total cost to satisfy the yogurt schedule. Note that the total might be too large for a 32-bit integer.

Sample Input

4 5
88 200
89 400
97 300
91 500

Sample Output

126900

Hint

OUTPUT DETAILS: 
In week 1, produce 200 units of yogurt and deliver all of it. In week 2, produce 700 units: deliver 400 units while storing 300 units. In week 3, deliver the 300 units that were stored. In week 4, produce and deliver 500 units. 
//poj2393(贪心)
//题目大意:工厂每周都要生产ans[i].v升的酸奶,当生产酸奶的原奶的价格每周都会波动。
//不过,在完成本周要产的量之外,还可以继续生产不限量的酸奶存起来当作以后要生产的酸奶。
//且已知每升酸奶存一周需要支付 s元的现金。问要按时完成每周的指标。最少的成本是多少?
//解题思路:就是贪心,首先第一周肯定没法往后托,以后每周都可以在本周和前几周之间选择
//一个最小的花费,作为本周完成指标的费用。依次类推。最终得到的就是最少的成本。(这个思路是对的,当放到本题就会超时) 
//这道题只需从本周和上一周选择一个最小的话费就行了。不过感觉这样并不能得到最小。比如: 
// 3 5
//80 200
//100 400
//200 100
//这组数据如果只判断本周和上一周的最小的花费作为这一周的花费。得到的总费用是60500 ,可以 AC.
//如果选择本周和其前几周之间一个生成本周酸奶费用最少的一个的话,最后得到的费用是59000.(不过这样会超时) 
//没错,就是这莫坑。 
#include<stdio.h>
#include<string.h>
struct p{
	int money;
	int v;
	__int64 total;
}ans[10010];
int main()
{
	__int64 n,s,i,j,k,sum,m;
	while(scanf("%I64d%I64d",&n,&s)!=EOF)
	{
		sum=0;
		for(i=0;i<n;i++)
		{
			scanf("%d%d",&ans[i].money,&ans[i].v);
			if(i==0)
			{
				ans[0].total=ans[0].money*ans[i].v;
			}
			else
			{
			     ans[i].total=ans[i].money*ans[i].v;//在本周生产本周的酸奶所需费用。
				 k=ans[i-1].money*ans[i].v+s*ans[i].v;//在上一周生产本周的酸奶所需费用。
				 if(ans[i].total>=k) ans[i].total=k;
			}
			sum+=ans[i].total;
		}
		printf("%I64d\n",sum);
	}
return 0;
}
//每次从本周和前几周中选一个生产本周牛奶最小的花费作为本周的花费。 
//int main()
//{
//	__int64 n,s,i,j,k,sum,m;
//	while(scanf("%I64d%I64d",&n,&s)!=EOF)
//	{
//		sum=0;
//		for(i=0;i<n;i++)
//		{
//			scanf("%d%d",&ans[i].money,&ans[i].v);
//			if(i==0)
//			{
//				ans[0].total=ans[0].money*ans[i].v;
//			}
//			else
//			{
//			     ans[i].total=ans[i].money*ans[i].v;//在本周生产本周的酸奶所需费用。 
//			     for(j=0;j<i;j++)
//				 { 
//				  k=ans[j].money*ans[i].v+s*(i-j)ans[i].v; //在前几周生产本周酸奶所需费用。 
//				  if(ans[i].total>=k) ans[i].total=k;//选出最小的那个 
//				  } 
//			}
//			sum+=ans[i].total;//加到总费用中 
//		}
//		printf("%I64d\n",sum);
//	}
//return 0;
//}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bokzmm

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值