hdu1114Piggy-Bank(完全背包变形)

Piggy-Bank

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17614    Accepted Submission(s): 8881


Problem Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!
 

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.
 

Output
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".
 

Sample Input
  
  
3 10 110 2 1 1 30 50 10 110 2 1 1 50 30 1 6 2 10 3 20 4
 

Sample Output
  
  
The minimum amount of money in the piggy-bank is 60. The minimum amount of money in the piggy-bank is 100. This is impossible.
题意大意: 有一个小猪存钱罐,重量为w1,装满钱币后的重量为w2,另外知道n种硬币,每个硬币的面值为v,重量为w;
问在装满存钱罐的情况下,所需的最小钱币的面值。
解题思路:完全背包的变形,经典的完全背包是在不超过背包容量的情况下求最大的权值,这里是求在装满背包的情况下求最小的权值。
所以除了初始化外,其余都是完全背包。下面就说一下初始化问题:
背包问题中有两种初始化情况。一种是在不超过背包容量的情况下求最大权值,一种是在装满背包的情况下求最大权值。
对于第一种情况,由于不限定必须装满背包,所以初始时对于所有容量的背包都初始化为零就可以啦(即只要背包容量满足就可以装);而第二种
只有第一个dp[0][0]容量为0的背包可能被价值为0的恰好装满,其余都应该初始化为负无穷大,才能保证在装满情况的权值最大。其动态转移方程为
完全背包:dp[i+1][j]=max(dp[i][j],dp[i+1][j-w[i]]+v[i]);
而如果要求在装满背包
的情况下求得最小权值,第一个dp[0][0]=0,其余都初始化为无穷大,然后将上述每次的转移方程为:
dp[i+1][j]=min(dp[i][j],dp[i+1][j-w[i]]+v[i]);就是本题的动态转移方程
AC代码:
#include<stdio.h>
#include<string.h>
int dp[1010][1010],n,m;
int min(int x,int y)
{
	if(x>y) return x;
	else    return y;     //求最小值函数
}
struct p{
	int v,w;
}ans[1010];
void init()
{
	int i,j;
	for(i=0;i<=n;i++)
	{
		for(j=0;j<=m;j++)
		{
			dp[i][j]=-1000;    //初始化函数
		}
	}
}
int main()
{
	int i,j,k;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		for(i=0;i<n;i++)
		{
			scanf("%d%d",&ans[i].v,&ans[i].w);
		}
		init();
		dp[0][0]=0;                              //dp[0][0]初始化为零
		for(i=0;i<n;i++)
		{
		 for(j=0;j<=m;j++)
		 {
		 	if(j<ans[i].w)
		 	 dp[i+1][j]=dp[i][j];
		 	else
		 	 dp[i+1][j]=min(dp[i][j],dp[i][j-ans[i].w]+ans[i].v);
		 }
		}
	printf("%d\n",dp[n][m]);
	}
return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bokzmm

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值