hdu1027(dfs)

22 篇文章 0 订阅

Ignatius and the Princess II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6376    Accepted Submission(s): 3772


Problem Description
Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."

"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......"
Can you help Ignatius to solve this problem?
 

Input
The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file.
 

Output
For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.
 

Sample Input
  
  
6 4 11 8
 

Sample Output
  
  
1 2 3 5 6 4 1 2 3 4 5 6 7 9 8 11 10
 

//题目大意:给你一个数n,求由1~n(n<=1000)组成的排列中第m(m<=10000)个排列?
//由于m的范围最大 为10000;而数n的全排列中n=8时的排列数就有40320.所以对于n>8的排列
// 1~(n-8-1)直接按顺序输出,可知,只需从(n-8)开始枚举(n-8)~n排列的第m个也就是1~n的第m个排列。这样就不会超时啦。 
#include<stdio.h>
#include<string.h>
int n,m,a[10],vis[10010],v,cnt,flag;
void init()
{
    	v=1;
		cnt=0;
		flag=0;
		memset(vis,0,sizeof(vis));
}
void dfs(int cur,int num,int nk)    //枚举排列函数 
{
	if(flag==1) return ;
	int i;
	if(cur==num+1)               //产生一个排列 
	{
		cnt++;                  //cnt++,记录排列的顺序 
		if(cnt==m)             //cnt==m时,找到 flag=1.
		{
		   flag=1  ;             
		   printf("%d",a[1]);
		   for(i=2;i<=nk;i++)
		   {
			printf(" %d",a[i]);
		   }
		   printf("\n");
	    }
		return ;
	}
	else
	{
		for(i=v;i<=n;i++)
		{
			a[cur]=i;
			if(!vis[i])
			{
				vis[i]=1;
				dfs(cur+1,num,nk);
				vis[i]=0;
			}
		}
	}
}
int main()
{
	int i,j,k;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		init();
		if(n>8)
		{
			k=n,j=1;
			while(k>8)               //n>8时,打印1~n-8-1的排列 
			{
				printf("%d ",j++);
				k--;
			}
			v=j;
			dfs(1,8,8);          //搜索n-8~n中第m个排列。 
		}
		else 
		{
			dfs(1,n,n);        //n<=8时;直接搜索1~n的第m个排列即可. 
		}
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bokzmm

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值