PAT-A1126 Eulerian Path 题目内容及题解

In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)

Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N (≤ 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).

Output Specification:

For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph -- either Eulerian, Semi-Eulerian, or Non-Eulerian. Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

Sample Input 1:

7 12
5 7
1 2
1 3
2 3
2 4
3 4
5 2
7 6
6 3
4 5
6 4
5 6

Sample Output 1:

2 4 4 4 4 4 2
Eulerian

Sample Input 2:

6 10
1 2
1 3
2 3
2 4
3 4
5 2
6 3
4 5
6 4
5 6

Sample Output 2:

2 4 4 4 3 3
Semi-Eulerian

Sample Input 3:

5 8
1 2
2 5
5 4
4 1
1 3
3 2
3 4
5 3

Sample Output 3:

3 3 4 3 3
Non-Eulerian

题目大意

欧拉路径是图中每条边只经过一次的路径。类似地,欧拉回路是由相同顶点开始和结束的欧拉路径。图论证明了具有所有顶点度数均为偶数的连通图具有欧拉回路,这种图称为欧拉图。如果恰好有两个奇数度的顶点,所有的欧拉路径都从其中一个顶点开始,在另一个顶点结束。有欧拉路径但没有欧拉回路的图称为半欧拉图。题目给定一个无向图,要求给出它是欧拉的,半欧拉的,还是非欧拉的。

解题思路

  1. 初始化并读入数据,用邻接表储存无向图;
  2. 用DFS检查连通性(记录经过的节点数);
  3. 计算并输出每个节点的度数,并输出;
  4. 根据之前的判断确定其属性并输出;
  5. 返回零值。

代码

#include<cstdio>
#include<vector>
using namespace std;
#define maxn 510

vector<int> Edge[maxn];
int N,M,num;
int vis[maxn];

void Init(){
    int a,b;
    scanf("%d%d",&N,&M);
    while(M--){
        scanf("%d%d",&a,&b);
        Edge[a].push_back(b);
        Edge[b].push_back(a);
    }
}

void DFS(int v){
    int i;
    vis[v]=1;
    num++;
    for(i=0;i<Edge[v].size();i++){
        if(vis[Edge[v][i]]==0){
            DFS(Edge[v][i]);
        }
    }
}

void Print(){
    int i,odd=0,temp;
    DFS(1);
    for(i=1;i<=N;i++){
        temp=Edge[i].size();
        if(temp%2){
            odd++;
        }
        printf("%d",temp);
        if(i==N){
            printf("\n");
        }else{
            printf(" ");
        }
    }
    if(num==N&&odd==0){
        printf("Eulerian\n");
    }else if(num==N&&odd==2){
        printf("Semi-Eulerian\n");
    }else{
        printf("Non-Eulerian\n");
    }
}

int main(){
    Init();
    Print();
    return 0;
}

运行结果

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值