Intersecting Lines

Intersecting Lines

Time Limit: 1000m              Case Time Limit: 30000ms
                                   Memory Limit: 10000KB
64-bit integer IO format:  lld     
              Java class name:  Main

We all know that a pair of distinct points on a plane defines a line and that a pair of lines on a plane will intersect in one of three ways: 1) no intersection because they are parallel, 2) intersect in a line because they are on top of one another (i.e. they are the same line), 3) intersect in a point. In this problem you will use your algebraic knowledge to create a program that determines how and where two lines intersect. 
Your program will repeatedly read in four points that define two lines in the x-y plane and determine how and where the lines intersect. All numbers required by this problem will be reasonable, say between -1000 and 1000. 

Input

The first line contains an integer N between 1 and 10 describing how many pairs of lines are represented. The next N lines will each contain eight integers. These integers represent the coordinates of four points on the plane in the order x1y1x2y2x3y3x4y4. Thus each of these input lines represents two lines on the plane: the line through (x1,y1) and (x2,y2) and the line through (x3,y3) and (x4,y4). The point (x1,y1) is always distinct from (x2,y2). Likewise with (x3,y3) and (x4,y4).

Output

There should be N+2 lines of output. The first line of output should read INTERSECTING LINES OUTPUT. There will then be one line of output for each pair of planar lines represented by a line of input, describing how the lines intersect: none, line, or point. If the intersection is a point then your program should output the x and y coordinates of the point, correct to two decimal places. The final line of output should read "END OF OUTPUT". 

Sample Input

5
0 0 4 4 0 4 4 0
5 0 7 6 1 0 2 3
5 0 7 6 3 -6 4 -3
2 0 2 27 1 5 18 5
0 3 4 0 1 2 2 5

Sample Output

INTERSECTING LINES OUTPUT
POINT 2.00 2.00
NONE
LINE
POINT 2.00 5.00
POINT 1.07 2.20
END OF OUTPUT

参考链接点击打开链接

题目大意:求两条直线的交点坐标。

解题关键:叉积的运用。

证明:

直线的一般方程为F(x)=ax+by+c=0F(x)=ax+by+c=0。既然我们已经知道直线的两个点,假设为(x0,y0),(x1,y1)(x0,y0),(x1,y1),那么可以得到a=y0y1a=y0−y1,b=x1x0b=x1–x0,c=x0y1x1y0c=x0y1–x1y0

因此我们可以将两条直线分别表示为

F0(x)=a0x+b0y+c0=0,F1(x)=a1x+b1y+c1=0F0(x)=a0x+b0y+c0=0,F1(x)=a1x+b1y+c1=0

那么两条直线的交点应该满足

a0x+b0y+c0=a1x+b1y+c1a0x+b0y+c0=a1x+b1y+c1

由此可推出

x=(b0c1b1c0)/D

y=(a1c0a0c1)/D

D=a0b1a1b0D=a0b1−a1b0 (D为0时,表示两直线平行)


#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cstdlib>
#include<cmath>
#include<iostream>
#define pi acos(-1)
using namespace std;
typedef long long ll; 
const double eps=1e-8;
const int N=5,maxn=100005,inf=0x3f3f3f3f;
struct point{
    double x,y;
};
struct line{
   point a,b;
}l[N];

int main(){
    int t;
    double x1,x2,x3,x4,y1,y2,y3,y4;
    cin>>t;
    cout<<"INTERSECTING LINES OUTPUT"<<endl;
    while(t--){
        cin>>x1>>y1>>x2>>y2>>x3>>y3>>x4>>y4;
        if((x4-x3)*(y2-y1)==(y4-y3)*(x2-x1)){//即上面讲的两个直线平行的条件a0b1=a1b0
            if((x2-x1)*(y3-y1)==(y2-y1)*(x3-x1)) cout<<"LINE"<<endl;//用叉积判断共线
            else cout<<"NONE"<<endl;
        }
        else{
            double a1=y1-y2,b1=x2-x1,c1=x1*y2-x2*y1;//c是叉积 
            double a2=y3-y4,b2=x4-x3,c2=x3*y4-x4*y3;
            double x=(c2*b1-c1*b2)/(b2*a1-b1*a2);
            double y=(a2*c1-a1*c2)/(b2*a1-b1*a2);
            printf("POINT %.2f %.2f\n",x,y);
        }
    }
    cout<<"END OF OUTPUT"<<endl;
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值