[PAT-甲级]1007.Maximum Subsequence Sum

1007. Maximum Subsequence Sum (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4

解题思路:题意求最大连续子段和,并且打印最大连续子序列是从哪个元素开始,哪个元素结束(打印开始元素和结束元素的数值,不是下标,切记)。采用两种元素,一种常规法,另外一种动态规划的方法。

需要注意,如果元素都为负数,则最大连续子段和为0,并打印第一个元素值和最后一个元素值

常规法代码如下:

include<stdio.h>

int buf[10010];

int main()
{
	int n;
	// flag 标记是否全部是负数 
	bool flag = true; 
	scanf("%d", &n);
	
	for(int i = 0; i < n; i ++)
	{
		scanf("%d", &buf[i]);
		if(buf[i] >= 0)
			flag = false;
	}
	
	
	if(flag)
	{
		printf("0 %d %d\n", buf[0], buf[n-1]);
		return 0;
	}
	
	int start = 0, end;
	int max = -1, sum = 0;
	// 找到右边下标 
	for(int i = 0; i < n; i ++)
	{
		sum += buf[i];
		
		if(sum > max)
		{
			max = sum;
			end = i;
		}
		else if (sum < 0)
			sum = 0;

	}
	
	max = -1;
	sum = 0;
	// 找到左边下标 
	for(int i = end; i >= 0; i --)
	{
		sum += buf[i];
		
		if(sum > max)
		{
			max = sum;
			start = i;
		}
		else if(sum < 0)
			sum = 0;
	}
	
	printf("%d %d %d\n", max, buf[start], buf[end]);
	
	return 0;
} 

动态规划代码如下:

#include<stdio.h>

int buf[10010];
// dp[i]保存以buf[i]为结尾的连续序列的最大和 
int dp[10010];
// s[i]表示产生dp[i]的连续序列从buf的哪一个元素开始 
int start[10010] = {0};

int main()
{
	int n;
	bool flag = true;
	scanf("%d", &n);
	
	for(int i = 0; i < n; i ++)
	{
		scanf("%d", &buf[i]);
		if(buf[i] >= 0)
			flag = false;
	}
	
	if(flag)
	{
		printf("0 %d %d\n", buf[0], buf[n-1]);
		return 0;
	}
	
	// 边界 
	dp[0] = buf[0];
	for(int i = 1; i < n; i ++)
	{
		//状态转移方程
		//buf[i]是一个非负数 
		if(dp[i-1] + buf[i] > buf[i])
		{
			dp[i] = dp[i-1] + buf[i];
			start[i] = start[i-1];	
		}
		else
		{
			dp[i] = buf[i];
			start[i] = i;
		} 
	}
	
	// 遍历找到最大的连续子段和 
	int k = 0;
	for(int i = 1; i < n; i ++)
	{
		if(dp[i] > dp[k])
			k = i;
	}
	printf("%d %d %d\n", dp[k], buf[start[k]], buf[k]);
	
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值