(hdu step 4.3.2)Prime Ring Problem(n个数成环,输出两两之和为质数的所有情况)

题目:

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 467 Accepted Submission(s): 297
 
Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

 
Input
n (0 < n < 20).
 
Output

            The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 
Sample Input
6
8
 
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
 
 
Source
Asia 1996, Shanghai (Mainland China)
 
Recommend
JGShining
 


题目分析:

               简单题。用DFS来做。需要注意的是第n个数还需要判断一下和1的和是否是一个质数。需要注意的是,和上一道题相比,这一道题是一道一维的DFS题目,而上一道是一道二维的DFS题目。所以这一道题并没有开用於包村地图信息的map[][]。


DFS的规则如下:

1)访问一个邻接的未访问结点,并将其入栈

2)如果不能执行规则1),则出栈一个元素

3)如果不能执行规则1)2),则说明遍历已经完成


代码如下:

/*
 * b.cpp
 *
 *  Created on: 2015年2月24日
 *      Author: Administrator
 */




#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>


using namespace std;

const int maxn = 21;
int value[maxn];//用来存储最后的符合要求的结果队列
bool visited[maxn];//用于标记某一个数是否访问过

int n;

/**
 * 判断某一个数n是否是质数
 */
bool isPrime(int n){
	int i;
	for(i = 2 ; i <= sqrt(n) + 0.5 ; ++i ){//如果一个数是合数,name它必然有一个因子是<sqrt(n)的
		if(n%i == 0){//如果它能整除i
			return false;//说明他不是质数
		}
	}

	return true;//说明他是质数
}

/**
 * 输出符合要求的结果队列
 */
void printValues(){
	int i;
	for(i = 1 ; i < n ; ++i){
		printf("%d ",value[i]);
	}
	printf("%d\n",value[n]);

}

/**
 * 深搜
 * cnt:目前搜索到的步数
 */
void dfs(int cnt){

	//如果已经走完n步,并切蒂n个数和第1个数之和是质数
	if(cnt == (n+1) && isPrime(value[cnt-1] + 1)){
		printValues();//name这种情况是符合要求的情况,输出所有结果
	}

	int i;
	for(i = 2 ; i <= n ; ++i){//遍历每一个数,看他是否合适加入到现在这种情况的结果队列中
		//如果i没有没访问过&&目前结果序列的最后一个数与i的和是一个质数
		if((visited[i] == false) && isPrime(i+value[cnt-1])){
			visited[i] = true;//将i标记为已经访问过
			value[cnt] = i;//将i加入到结果序列中
			dfs(cnt+1);//沿着该序列寻找下一个合适的数
			visited[i] = false;//上面一种情况已经考虑完,将i重新设置成未访问过.用于考虑下一情况
		}
	}
}

int main(){
	int counter = 1;
	while(scanf("%d",&n)!=EOF){
		memset(visited,false,sizeof(visited));
		printf("Case %d:\n",counter);
		value[1] = 1;//序列的第1个数永远是1
		visited[1] = true;
		dfs(2);//从第2步开始搜索

		printf("\n");
		counter++;

	}

	return 0;
}




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

帅气的东哥

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值