HDU.1003【max-sum】---16.2.3

    第一次开通博客,想以这样一个平台来记录我接下来的ACM的奋斗之路。

   虽然是女生,但是我相信男生可以的我相信我就可以。

   在不知道对手的情况下,只要奋发努力尽力做到最好就可以了。

不说废话了,切入主题:

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 197539    Accepted Submission(s): 46151

Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 


Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 


Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 


Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 


Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6

代码如下:

#include <stdio.h>
int a[100001];
int main()
{
    int casenumber, number, k = 0, i;
    int position, xbegin, xend;
    int maxsum, thissum;
    scanf("%d",&casenumber);
    while(casenumber--)
    {
        k ++;
        scanf("%d",&number);
        for(i = 1; i <= number; i ++)
        {
            scanf("%d", &a[i]);
        }
        position = 1;
        xbegin = xend = 0;

        thissum  = 0;
        maxsum = -9999;
        for(i = 1; i <= number; i++)
        {
            thissum += a[i];
            if(thissum > maxsum)
            {
                maxsum=thissum;
                xbegin=position;
                xend=i;
            }
            if(thissum < 0)
            {
                thissum = 0;
                position = i+1;
            }
        }
        printf("Case %d:\n%d %d %d\n",k,maxsum,xbegin,xend);
        if(casenumber)//这里去掉 -1,因为while先判断了,然后执行casenumber=casenumb-1,最后一次的时候casenumber已经等于0了
            printf("\n");
    }
    return 0;
}

总结:这道题的基本思想是求最大子序列,用每个数加进去都计算一遍的方法:1.若当前和大于最大和(xbegin始终等于posion):改变最大和的值,同时改变begin,end的值,当前位置position就是最大子序列的第一个数的位置,i移动到哪里,哪里就是当前最大子序列最后一个位置。2.若前i项为负的,从第i+1项重新开始做(position = i+1,thissum = 0):前面的和若为负,再加谁,就相当于a[i]减去了前面的数,和一定会减小,此时只需将position放到下一位。

还要多谢我哥们不厌其烦的给我改代码【感动脸】

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值