动态规划训练7 [Halloween Costumes ]

Gappu has a very busy weekend ahead of him. Because, next weekend is Halloween, and he is planning to attend as many parties as he can. Since it's Halloween, these parties are all costume parties, Gappu always selects his costumes in such a way that it blends with his friends, that is, when he is attending the party, arranged by his comic-book-fan friends, he will go with the costume of Superman, but when the party is arranged contest-buddies, he would go with the costume of 'Chinese Postman'.

Since he is going to attend a number of parties on the Halloween night, and wear costumes accordingly, he will be changing his costumes a number of times. So, to make things a little easier, he may put on costumes one over another (that is he may wear the uniform for the postman, over the superman costume). Before each party he can take off some of the costumes, or wear a new one. That is, if he is wearing the Postman uniform over the Superman costume, and wants to go to a party in Superman costume, he can take off the Postman uniform, or he can wear a new Superman uniform. But, keep in mind that, Gappu doesn't like to wear dresses without cleaning them first, so, after taking off the Postman uniform, he cannot use that again in the Halloween night, if he needs the Postman costume again, he will have to use a new one. He can take off any number of costumes, and if he takes off k of the costumes, that will be the last k ones (e.g. if he wears costume Abefore costume B, to take off A, first he has to remove B).

Given the parties and the costumes, find the minimum number of costumes Gappu will need in the Halloween night.

Input

Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case starts with a line containing an integer N (1 ≤ N ≤ 100) denoting the number of parties. Next line containsN integers, where the ith integer ci (1 ≤ ci ≤ 100) denotes the costume he will be wearing in party i. He will attend party 1 first, then party 2, and so on.

Output

For each case, print the case number and the minimum number of required costumes.

Sample Input

2

4

1 2 1 2

7

1 2 1 1 3 2 1

Sample Output

Case 1: 3

Case 2: 4

题目大意:

一个人要去参加一些列化妆舞会,而每场化妆舞会所要穿的衣服可能是不相同的,这个人可以穿上一件新的衣服以适应这个舞会,当然他也可以脱掉一些衣服,把里面的衣服露出来,以适应这个舞会。也就是说,这个人可以一下子穿好多件衣服。

样例分析:

第一个样例中,这个人先穿1,再穿2,再脱2,再穿2,总共需要3件新衣服。

在第二个样例中,这个人穿1,穿2,脱2,不变,穿3,脱3穿2,脱2。总共需要4件新衣服。

这道题目是一个比较明显的区间DP问题,而得到状态转移方程的关键是采用决策法。

对于一个区间dp[i][j],我们只需要考虑最后一个舞会所需要穿的衣服(也就是j),现在只有两种决策,一种是穿上一件新衣服,另一种方案是脱下x件衣服。

穿上一件新衣服这个决策的转移非常简单dp[i][j] = dp[i][j-1] + 1

而脱下x件衣服就不那么明显了,我们要脱下x件衣服最终得到目标衣服,所以dp[i][j] = min(dp[i][j],dp[i][k]+dp[k+1][j]) 其中yifu[k] == yifu[j];

注意,脱下的这些衣服一定是适用区间[k+1][j]的,这也就是为什么后面要加上dp[k+1][j]

#include <algorithm>
#include <cstdio>
#include <cstring> 
using namespace std;
const int MAX = 105;
int dp[MAX][MAX];
int a[MAX];
int main(){
	int T,cas = 0;
	scanf("%d",&T);
	while(T--){
		memset(dp,0,sizeof(dp));
		int N;scanf("%d",&N);
		for(int i = 0;i < N;i++){
			scanf("%d",&a[i]);
		}
		for(int i = 0;i < N;i++) dp[i][i+1] = 1;
		for(int k = 2;k <= N;k++){
			for(int i = 0;i + k <= N;i++){
				int end = i + k;
				dp[i][end] = 1 + dp[i][end-1];
				for(int j = i+1;j < end;j++){
					if(a[end-1] == a[j-1]){
						dp[i][end] = min(dp[i][end],dp[i][j] + dp[j][end-1]);
					} 
				}
			}
		} 
		printf("Case %d: %d\n",++cas,dp[0][N]);
	}
	return 0;
} 






  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值