LightOJ 1220 Mysterious Bacteria

题目链接:点我


Dr. Mob has just discovered a Deathly Bacteria. He named it RC-01. RC-01 has a very strange reproduction system. RC-01 lives exactly x days. Now RC-01 produces exactly p new deadly Bacteria where x = bp (where b, p are integers). More generally, x is a perfect pth power. Given the lifetime x of a mother RC-01 you are to determine the maximum number of new RC-01 which can be produced by the mother RC-01.

Input

Input starts with an integer T (≤ 50), denoting the number of test cases.

Each case starts with a line containing an integer x. You can assume that x will have magnitude at least 2 and be within the range of a 32 bit signed integer.

Output

For each case, print the case number and the largest integer p such that x is a perfect pth power.

Sample Input

3

17

1073741824

25

Sample Output

Case 1: 1

Case 2: 30

Case 3: 2

题意:

给你一个公式 x=bp , 给你一个数x,求最大的p.

思路:

唯一分解定理:x = pe11 * pe22 * pe33 ….,那么根据题意所有ans = gcd( e1 , e2 , e3 …….);而且这里,如果x为负数的话,那么ans一定只能是奇数.
代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<iostream>
using namespace std;

typedef long long LL;
const int maxn = 1e6 + 10;
bool vis[maxn];
int pri[maxn/10];
int k , num = 0;
LL n, ans;
bool flag;
LL a[1000];

void prime(){
    memset(vis,false,sizeof(vis));
    for(int i = 2; i < maxn; ++i){
        if (!vis[i]) pri[++num] = i;
        for(int j = 1;j <= num && i *pri[j] < maxn; ++j){
            vis[i * pri[j]] = true;
            if (i % pri[j] == 0) break;
        }
    }
}

LL gcd(LL a, LL b){
    return b ? gcd(b, a % b) : a;
}

void solve(){
    for(int i = 1; i <= num && pri[i] <= (int)sqrt(n); ++i){
            int cnt = 0;
            while(n % pri[i] == 0){
                ++cnt;
                n /= pri[i];
            }
            if(cnt) a[++k] = cnt;
            if (cnt == 1){
                ans = 1;
                return ;
            }
        } if(n > 1) {
            ans = 1;
            return ;
            }
    int tmp = a[1];
    for(int i = 2; i <= k; ++i){
        tmp = gcd( tmp, a[i]);
    }
    if(flag){//如果n为奇数,那么ans 只能为奇数,
        while(tmp % 2 ==0)
            tmp /= 2;
    }
    ans = tmp;
}


int main(){
    int t, kase = 0;
    prime();
    scanf("%d", &t);
    while( t--){
        scanf("%lld", &n);
        flag = false;
        if(n < 0){
            flag = true;
            n = -n;
        }
        k = 0;
        ans = 0;
        solve();
        printf("Case %d: %lld\n", ++kase, ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值