poj 2195 二分图最优匹配KM算法 模板题

点击打开题目

Going Home
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 23815 Accepted: 11970

Description

On a grid map there are n little men and n houses. In each unit time, every little man can move one unit step, either horizontally, or vertically, to an adjacent point. For each little man, you need to pay a $1 travel fee for every step he moves, until he enters a house. The task is complicated with the restriction that each house can accommodate only one little man. 

Your task is to compute the minimum amount of money you need to pay in order to send these n little men into those n different houses. The input is a map of the scenario, a '.' means an empty space, an 'H' represents a house on that point, and am 'm' indicates there is a little man on that point. 

You can think of each point on the grid map as a quite large square, so it can hold n little men at the same time; also, it is okay if a little man steps on a grid with a house without entering that house.

Input

There are one or more test cases in the input. Each case starts with a line giving two integers N and M, where N is the number of rows of the map, and M is the number of columns. The rest of the input will be N lines describing the map. You may assume both N and M are between 2 and 100, inclusive. There will be the same number of 'H's and 'm's on the map; and there will be at most 100 houses. Input will terminate with 0 0 for N and M.

Output

For each test case, output one line with the single integer, which is the minimum amount, in dollars, you need to pay.

Sample Input

2 2
.m
H.
5 5
HH..m
.....
.....
.....
mm..H
7 8
...H....
...H....
...H....
mmmHmmmm
...H....
...H....
...H....
0 0

Sample Output

2
10
28
这个题是最标准的二分图最优匹配,KM算法模板题,KM算法是求最大权值匹配,这个题是求最小权值匹配,因此只要将权值换成负数就可以巧妙的用KM算法了,KM算法很难搞懂,就先拿个简单题练练手了
#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#include<algorithm>
using namespace std;
struct node
{
	int x,y;
}M[10000],H[10000];
char map[101][101];
int w[101][101];
int usex[101],usey[101];
int lx[101],ly[101];
int link[101];
int n,m,top1,top2;
void init()
{
	int i,j,t;
	top1=top2=0;
	for(i=0;i<n;i++)
	for(j=0;j<m;j++)
	{
		if(map[i][j]=='m')
		M[++top1].x=i,M[top1].y=j;
		else if(map[i][j]=='H')
		H[++top2].x=i,H[top2].y=j;
	}
	for(i=1;i<=top1;i++)
	for(j=1;j<=top2;j++)
	{
		t=abs(M[i].x-H[j].x)+abs(M[i].y-H[j].y);
		w[i][j]=-t;//KM算法是最大权值匹配,因此改为负数 
	}
}
int dfs(int u)
{
	usex[u]=1;
	for(int i=1;i<=top2;i++)
	if(!usey[i]&&lx[u]+ly[i]==w[u][i])
	{
		usey[i]=1;
		if(!link[i]||dfs(link[i]))
		{
			link[i]=u;
			return 1;
		}
	}
	return 0;
}
void update()
{
	int i,j,a=99999;
	for(i=1;i<=top1;i++)
	if(usex[i])
	for(j=1;j<=top2;j++)
	{
		if(!usey[j])
		a=min(a,lx[i]+ly[j]-w[i][j]);
	}
	
	for(i=1;i<=top1;i++)
	{
		if(usex[i])
		lx[i]-=a;
		if(usey[i])
		ly[i]+=a;
	}
}
int KM()
{
	int i,j,ans=0;
	memset(lx,-9999999,sizeof(lx));
	memset(ly,0,sizeof(ly));
	memset(link,0,sizeof(link));
	for(i=1;i<=top1;i++)
	for(j=1;j<=top2;j++)
	lx[i]=max(lx[i],w[i][j]);
	for(i=1;i<=top1;i++)
	{
		while(1)
		{
			memset(usex,0,sizeof(usex));
			memset(usey,0,sizeof(usey));
			if(dfs(i))
			break;
			else
			update();
		}
	}
	for(i=1;i<=top2;i++)
	ans+=w[link[i]][i];
	return -ans;
}
int main()
{
	while(~scanf("%d%d",&n,&m)&&n&&m)
	{
		int i;
		for(i=0;i<n;i++)
		scanf("%s",map[i]);
		init();
		printf("%d\n",KM()) ;
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

长沙橘子猫

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值