1040 Longest Symmetric String (25 分) 动态规划求字符串最大回文子串长度

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given Is PAT&TAP symmetric?, the longest symmetric sub-string is s PAT&TAP s, hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:

For each test case, simply print the maximum length in a line.

Sample Input:

Is PAT&TAP symmetric?

Sample Output:

11
题意:给出一个字符串,求它的最大回文子串长度
思路:先考虑清楚字符串的边界,先假设ans=1,本身是回文的,再如果相邻的两个相等的话,ans=2,再从L=3开始列举到字符串的长度,j=i+L-1为当前循环的右边下标,如果满足s[i]=s[j]并且dp[i+1][j-1]等于1的情况下,dp[i][j]等于1并且ans=L,最后输出字符串的最大回文子串长度。

#include<iostream>
#include<cstdio>
#include<stack> 
#include<queue>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<cmath>
#include<set>
#include<map>

using namespace std;

string s;
int dp[1010][1010] = {0};

int main() {
	getline(cin,s);
	int length = s.length();
	int ans = 1;
	//边界
	for(int i = 0;i < length - 1;i++) {
		dp[i][i] = 1;
		if(s[i] == s[i + 1]) {
			dp[i][i + 1] = 1;
			ans = 2;
		}
	}
	//dp 
	for(int L = 3;L <= length;L++) {
		for(int i = 0;i + L - 1 < length;i++) {
			int j = i + L - 1;
			if(s[i] == s[j] && dp[i + 1][j - 1] == 1) {
				dp[i][j] = 1;
				ans = L;
			}
		}
	}
	printf("%d\n",ans);
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值