poj-2965 The Pilots Brothers' refrigerator

4 篇文章 0 订阅

Description

The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.

There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location [i, j] (1 ≤ i, j ≤ 4). However, this also changes states of all handles in row i and all handles in column j.

The task is to determine the minimum number of handle switching necessary to open the refrigerator.

Input

The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “−” means “open”. At least one of the handles is initially closed.

Output

The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions, you may give any one of them.

Sample Input

-+--
----
----
-+--

Sample Output

6
1 1
1 3
1 4
4 1
4 3
4 4
    这道题和poj-1753非常相似,实际上只是把之前1753的代码改了改,修改后用C++和C提交都会超时,用G++才可以AC,耗时969MS(也是够极限)

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define INF 0x3f3f3f3f
int map[4][4],flag[4][4],mapx[4][4];
int flag1=0,k;
void fun(int step,int m)
{
        int i,j,t=0,l;
        if(flag1) return ;
        if(step==k)
        {
                for (i=0;i<16;i++)
                {
                        mapx[i/4][i%4]=map[i/4][i%4];
                }
                for (i=0;i<4;i++)
                {
                        for (j=0;j<4;j++)
                        {
                                if(flag[i][j])
                                {
                                        if(mapx[i][j]) mapx[i][j]=0;
                                        else mapx[i][j]=1;
                                        for (l=0;l<4;l++)
                                        {
                                                if(mapx[i][l]) mapx[i][l]=0;
                                                else mapx[i][l]=1;
                                                if(mapx[l][j]) mapx[l][j]=0;
                                                else mapx[l][j]=1;
                                        }
                                }
                        }
                }
                for (i=0;i<4;i++)
                {
                        for (j=0;j<4;j++)
                        {
                                if(mapx[i][j]==1)
                                t++;
                        }
                }
                if(t==16) flag1=1;
                return ;
        }
        for (i=m+1;i<16;i++)
        {
                flag[i/4][i%4]=1;
                fun(step+1,i);
                if(flag1) return ;
                flag[i/4][i%4]=0;
        }
}
int main()
{
        char c;
        int i,j;
        for (i=0;i<16;i++)
        {
                scanf("%c",&c);
                if((i+1)%4==0)    getchar();
                if(c=='-')
                {
                        map[i/4][i%4]=1;
                }
                else if(c=='+')
                {
                        map[i/4][i%4]=0;
                }
        }
        for (i=0;i<=16;i++)
        {
                memset(flag,0,sizeof(flag));
                k=i;
                fun(0,-1);
                if(flag1) break;
        }
        if(flag1)
        {
                printf("%d\n",i);
                for (i=0;i<4;i++)
                {
                        for (j=0;j<4;j++)
                        {
                                if(flag[i][j])
                                printf("%d %d\n",i+1,j+1);
                        }
                }
        }
        return 0;
}

    其实还有另外一种很巧的写法,这是在其他人博客里看到的。

#include<stdio.h>
#include<string.h>
#include<stdlib.h>

char ls[4][4];
bool map[4][4];
void change(int a,int b)
{
    map[a][b] = !map[a][b];
}
int main()
{
    int i, j;
    for(i = 0; i < 4; i++)
    {
        scanf("%s",ls[i]);
    }
    for(i = 0; i < 4; i++)
    {
        for(j = 0; j < 4; j++)
        {
            if(ls[i][j] == '+')
            {
                for(int k = 0; k < 4; k++)
                {
                    change(i,k);
                }
                for(int k = 0; k < 4; k++)
                {
                    change(k,j);
                }
                change(i,j);
            }

        }
    }
    int c = 0;
    for(i = 0; i < 4; i++)
    {
        for(j = 0; j < 4; j++)
        {
            if(map[i][j] == true)
                c++;
        }
    }
    printf("%d\n",c);
    for(i = 0; i < 4; i++)
    {
        for(j = 0; j < 4; j++)
        {
            if(map[i][j] == true)
                printf("%d %d\n",i+1,j+1);
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值