poj-1328 Radar Installation

3 篇文章 0 订阅

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1 
    一开始思考的时候最先想到的是找出横坐标上每个点能覆盖多少岛,后来发现雷达的坐标并不一定是整数。之后用了以岛做圆心,输入的d做半径与横坐标轴相交,记录下来每个相交区间。将相交区间以左端点排序,起始标准位置为第一个区间的右端。之后跑循环时分为三种情况:第一,后一个区间完全在前一个区间内,此时要把标准位置更新到里面的区间的右端,避免误判。第二,区间交错相交,这样两个岛雷达的放置地有公共部分,可以pass了。第三,区间相离,这样就要把标准位置变更为后一个区间的右端,雷达数量累加。

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <math.h>
#include <algorithm>
using namespace std;

struct node
{
        double r,l;
}arr[5000];
bool cmp(node x,node y)
{
        return x.l < y.l;
}
int main()
{
        int n;
        int i,k=0;
        double x,y,d;
        while (scanf("%d%lf",&n,&d),n||d)
        {
                k++;
                int t=0,flag=1;
                for (i=0;i<n;i++)
                {
                        scanf("%lf%lf",&x,&y);
                        if(y>d)
                        {
                                flag=0;
                                continue;
                        }
                        arr[t].l=x-sqrt(d*d-y*y);
                        arr[t++].r=x+sqrt(d*d-y*y);
                }
                if(!flag)
                {
                        printf("Case %d: -1\n",k);
                        continue;
                }
                sort(arr,arr+n,cmp);
                double r=arr[0].r;
                int ans=1;
                for (i=1;i<n;i++)
                {
                        if(arr[i].r<r)
                        {
                                r=arr[i].r;
                        }
                        else if(arr[i].l>r)
                        {
                                ans++;
                                r=arr[i].r;
                        }
                }
                printf("Case %d: %d\n",k,ans);
        }
        return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值