poj 2182 lost cows

Lost Cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11018 Accepted: 7075

Description
N (2 <= N <= 8,000) cows have unique brands in the range 1..N. In a spectacular display of poor judgment, they visited the neighborhood ‘watering hole’ and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands.

Regrettably, FJ does not have a way to sort them. Furthermore, he’s not very good at observing problems. Instead of writing down each cow’s brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow.

Given this data, tell FJ the exact ordering of the cows.

Input
* Line 1: A single integer, N

  • Lines 2..N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on.

Output
* Lines 1..N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.

Sample Input

5
1
2
1
0

Sample Output

2
4
5
3
1


【分析】
树状数组+二分
k=a[i]+1,k即为在1~i中第k小的数
利用二分找出l,l即为第k-1小的数。把指针卡在这。(呵呵)
然后第i只奶牛的编号即为l+1(或者r)


【代码】

#include<iostream>
#include<cstdio>
#include<cstring>
#define fo(i,j,k) for(i=j;i<=k;i++)
using namespace std;
int a[10001],n,t[10001],b[10001];
inline int lowbit(int x) {return x&(-x);}
inline void inc(int x)
{
    while(x<=n) 
    {
        t[x]++;
        x+=lowbit(x);
    }
}
inline void dev(int x)
{
    while(x<=n)
    {
        t[x]--;
        x+=lowbit(x);
    }
}
inline int sum(int x)
{
    int ans=0;
    while(x>=1)
    {
        ans+=t[x];
        x-=lowbit(x);
    }
    return ans;
}
int main()
{
    int i,j,k;
    scanf("%d",&n);
    fo(i,2,n) scanf("%d",&a[i]);
    fo(i,1,n) inc(i);
    for(i=n;i>=1;i--)
    {
        k=a[i]+1;
        /*
        int l=1,r=n;
        while(l<r)
        {
            int mid=(l+r)/2+1;
            if(sum(mid)<=k) l=mid;
            else r=mid-1;
        }*/
        int l=0,r=n;
        while(r>l)
        {
            int mid=(l+r)/2+1;
            if(sum(mid)<k) l=mid;
            else r=mid-1;
        }
        b[i]=l+1;
        dev(l+1);
    }
    fo(i,1,n) printf("%d\n",b[i]);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值