POJ2230 Watchcow 【欧拉回路】+【DFS】

Watchcow
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 5964 Accepted: 2561 Special Judge

Description

Bessie's been appointed the new watch-cow for the farm. Every night, it's her job to walk across the farm and make sure that no evildoers are doing any evil. She begins at the barn, makes her patrol, and then returns to the barn when she's done. 

If she were a more observant cow, she might be able to just walk each of M (1 <= M <= 50,000) bidirectional trails numbered 1..M between N (2 <= N <= 10,000) fields numbered 1..N on the farm once and be confident that she's seen everything she needs to see. But since she isn't, she wants to make sure she walks down each trail exactly twice. It's also important that her two trips along each trail be in opposite directions, so that she doesn't miss the same thing twice. 

A pair of fields might be connected by more than one trail. Find a path that Bessie can follow which will meet her requirements. Such a path is guaranteed to exist.

Input

* Line 1: Two integers, N and M. 

* Lines 2..M+1: Two integers denoting a pair of fields connected by a path.

Output

* Lines 1..2M+1: A list of fields she passes through, one per line, beginning and ending with the barn at field 1. If more than one solution is possible, output any solution.

Sample Input

4 5
1 2
1 4
2 3
2 4
3 4

Sample Output

1
2
3
4
2
1
4
3
2
4
1

Hint

OUTPUT DETAILS: 

Bessie starts at 1 (barn), goes to 2, then 3, etc...

题意:给定n个点和m条路,求从1点出发每条路的两个方向都走一遍再回到原点的路径。

题解:有向欧拉图,链式前向星存图,DFS遍历回溯输出整张图。这题难在为什么回溯后输出的结果才是正确的,我想了一个上午,总算是有些头目了。对于欧拉回路,若从节点V0开始深搜,最后搜到无法继续的时候必定回到了V0点,所以若在回溯之前输出当前访问节点那么会出现一个问题,就是在搜索过程中,若漏掉了一个环,那么结果将是错误的,比如这样一个图v0->v1, v1->v2, v2->v1, v1->v0, 若在回溯前打印当前节点将可能出现这样的结果:v0->v1->v0->v2->v1, 显然是错误的,但是若在回溯后打印当前节点,最后的输出结果都是v0->v1->v2->v0,总会从出发点回到出发点的。

我累个去,这题代码看似简单,但是要想真正理解起来真不是件容易的事。



#include <stdio.h>
#include <string.h>
#define maxn 10002
#define maxm 50002

int n, m;
int head[maxn];
bool vis[maxm << 1];
struct Node{
	int to, next;
} edge[maxm << 1];

void Init()
{
	memset(head, -1, sizeof(head));
	memset(vis, 0, sizeof(vis));
}

void GetEdge()
{
	int i, a, b;
	m <<= 1;
	for(i = 0; i < m; ++i){
		scanf("%d%d", &a, &b);
		edge[i].to = b;
		edge[i].next = head[a];
		head[a] = i++;
		edge[i].to = a;
		edge[i].next = head[b];
		head[b] = i;
	}
}

void DFS(int k)
{
	for(int i = head[k]; i != -1; i = edge[i].next){
		if(!vis[i]){
			vis[i] = 1;
			DFS(edge[i].to);
		}
	}
	printf("%d\n", k);
}
int main()
{
	int i;
	while(scanf("%d%d", &n, &m) == 2){
		Init();
		GetEdge();
		DFS(1);
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值