hdu 1671-Phone List(字典树)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1671

Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.

Sample Input
2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output
NO
YES

和 hdu 1305-Immediate Decodability 一样 不想写 题解了

代码:

#include <iostream>
#include <bits/stdc++.h>
using namespace std;
struct node
{
    int t;
    node * child[10];
    node()
    {
        t = 0;
        for (int i=0; i<10; i++)
        {
            child[i] = NULL;
        }
    }
};
node *root;
int flag;
void build(char *a)
{
    node *p;
    node * newnode;
    int i;
    p = root;
    for (i=0; i<strlen(a); i++)
    {
        int m = a[i]-'0';
        //cout<<p->child[m]<<endl;
        if (p->child[m]!=NULL)    //如果树中存在改节点,查找是否结束
        {
            p = p->child[m];
            if (i==(strlen(a)-1)||p->t==1)
            {
                flag=1;
                break;
            }
        }
        else  //否则将节点插入树
        {
            newnode = new node;
            p->child[m] = newnode;
            p = newnode;

        }
    }
     p->t=1;
}
void ended(node *head)   //删除字典树
{
    for (int i=0; i<10; i++)
    {
        if (head->child[i]!=NULL)
            ended(head->child[i]);
    }
    delete head;
}
int main()
{
    char a[10001];
    int N;
    cin>>N;
    while (N--)
    {
        flag=0;
        memset(a,0,sizeof(a));
        root = new node;
        int n;
        scanf("%d",&n);
        for (int i=0; i<n; i++)
        {
            scanf("%s",a);
            build(a);
        }
        if (flag==1)
            cout<<"NO"<<endl;
        else
            cout<<"YES"<<endl;
        ended(root);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值