Cycles of Lanes

滴答滴答---题目链接 

Cycles of Lanes

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1809 Accepted: 663

Description

Each of the M lanes of the Park of Polytechnic University of Bucharest connects two of the N crossroads of the park (labeled from 1 to N). There is no pair of crossroads connected by more than one lane and it is possible to pass from each crossroad to each other crossroad by a path composed of one or more lanes. A cycle of lanes is simple when passes through each of its crossroads exactly once.
The administration of the University would like to put on the lanes pictures of the winners of Regional Collegiate Programming Contest in such way that the pictures of winners from the same university to be on the lanes of a same simple cycle. That is why the administration would like to assign the longest simple cycles of lanes to most successful universities. The problem is to find the longest cycles? Fortunately, it happens that each lane of the park is participating in no more than one simple cycle (see the Figure).
 

Input

On the first line of the input file the number T of the test cases will be given. Each test case starts with a line with the positive integers N and M, separated by interval (4 <= N <= 4444). Each of the next M lines of the test case contains the labels of one of the pairs of crossroads connected by a lane.

Output

For each of the test cases, on a single line of the output, print the length of a maximal simple cycle.

Sample Input

1 
7 8 
3 4 
1 4 
1 3 
7 1 
2 7 
7 5 
5 6 
6 2

Sample Output

4

Source

Southeastern European Regional Programming Contest 2009

#include<stdio.h>
#include<iostream>
#include<vector>
#include<algorithm>
#include<string.h>
using namespace std;

const int maxn=10010;
vector<int> v[maxn];
bool vis[maxn];
int ans;
int step[maxn];//记录搜索到某顶点时已搜索过的顶点数
void dfs( int x, int t)
{
    vis[x]=1;
    step[x]=t;//搜索到x时,已搜索过的顶点数
    for(size_t i=0; i<v[x].size(); i++)
    {
        if(!vis[v[x][i]])//没有发现环
            dfs(v[x][i],t+1);
        else//发现环
            ans=max(ans,step[v[x][i]]-step[x]+1);
    }
}

int main()
{

    int n,m,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(int i=1; i<=n; i++)
        {
            v[i].clear();
        }
        memset(vis,0,sizeof(vis));
        memset(step,0,sizeof(step));
        ans=0;
        while(m--)
        {
            int l,r;
            scanf("%d%d",&l,&r);
            v[l].push_back(r);
            v[r].push_back(l);
        }
        for(int i=1; i<=n; i++)
        {
            if(!vis[i])
                dfs(i,1);
        }
        printf("%d\n",ans);

    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值