大家都学过了布尔表达式的翻译,其中有一个拉链-回填技术,这次我们就练习这个技术。
注意,在布尔表达式中,“并且”运算的优先级是要高于“或者”运算的。
输入格式:
输入为一行字符串,例如: a < b or c < d and e < f
每个符号都用空格间隔。
其中逻辑运算符包含 and 和 or , 关系运算符包含 < 、> 、<= 、 >= 、== 、 != 。
输出格式:
假链跳到0,真链跳到1,表达式序号从100开始排。
输入样例1:
a < b or c < d and e < f
输出样例1:
100(j<,a,b,1)
101(j,_,_,102)
102(j<,c,d,104)
103(j,_,_,0)
104(j<,e,f,100)
105(j,_,_,103)
输入样例2:
a < b and c > d or e > f
输出样例2:
100(j<,a,b,102)
101(j,_,_,104)
102(j>,c,d,1)
103(j,_,_,101)
104(j>,e,f,102)
105(j,_,_,0)
#include <bits/stdc++.h>
using namespace std;
string a,x;
vector<string>d;
int main()
{
int id,yes,no;
getline(cin,a);
a+=" ed";
id=100;
yes=1;
no=100;
stringstream b(a);
while(b>>x)
{
if(x=="or"||x=="ed")
{
if(x=="or")no+=2;//每条or有两条语句
else no=0;//代表ed假链
int n=d.size();
for(int i=0; i<n-3; i+=3)
{
printf("%d(j%s,%s,%s,%d)\n",id,d[i+1].c_str(),d[i].c_str(),d[i+2].c_str(),id+2);//真时--
id++;
printf("%d(j,_,_,%d)\n",id,no);//假时
no=id++;//记住,下一次回填
}
printf("%d(j%s,%s,%s,%d)\n",id,d[n-2].c_str(),d[n-3].c_str(),d[n-1].c_str(),yes);
yes=id++;//记住,下一次回填
printf("%d(j,_,_,%d)\n",id,no);
id++;
d.clear();
if(x=="ed")break;
}
else if(x=="and")no+=2;//每geand有两条语句
else d.push_back(x);//遇到表达式就入栈
}
return 0;
}