Intersection(圆环相交)

Intersection

Time Limit: 4000/4000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 4408    Accepted Submission(s): 1681


 

Problem Description

Matt is a big fan of logo design. Recently he falls in love with logo made up by rings. The following figures are some famous examples you may know.


A ring is a 2-D figure bounded by two circles sharing the common center. The radius for these circles are denoted by r and R (r < R). For more details, refer to the gray part in the illustration below.


Matt just designed a new logo consisting of two rings with the same size in the 2-D plane. For his interests, Matt would like to know the area of the intersection of these two rings.

 

 

Input

The first line contains only one integer T (T ≤ 105), which indicates the number of test cases. For each test case, the first line contains two integers r, R (0 ≤ r < R ≤ 10).

Each of the following two lines contains two integers xi, yi (0 ≤ xi, yi ≤ 20) indicating the coordinates of the center of each ring.

 

 

Output

For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y is the area of intersection rounded to 6 decimal places.

 

 

Sample Input

 

2 2 3 0 0 0 0 2 3 0 0 5 0

 

 

Sample Output

 

Case #1: 15.707963 Case #2: 2.250778

 

 

Source

2014ACM/ICPC亚洲区北京站-重现赛(感谢北师和上交)

 

 

Recommend

liuyiding   |   We have carefully selected several similar problems for you:  6447 6446 6445 6444 6443 

描述
      自从shanghai reginal后,zkc学长的心理就有了阴影。什么不敢水题,不敢gj,不敢放松...(各种不敢)。同样的你们的zsj学长也是这样的。并且他们的心理阴影是一样一样的。
      已知一个人的心理阴影为一个环形,那么求你们的zkc学长和zjs学长站在一起的时候的心理阴影的重叠面积。
输入
T组数据
r,R表示是内圆半径和外圆半径。
x1,y1 zkc学长站的位置(抽象为一个点)
x2,y2 zjs学长站的位置(也抽象为一个点)
输出
Case #k: y
ps:k,第k组数据。y,你们的zkc学长和zjs学长站在一起的时候的心理阴影的重叠面积。
样例输入
2
2 3
0 0
0 0
2 3
0 0
5 0
样例输出
Case #1: 15.70796
Case #2: 2.25078
经分析可得:

两个圆环的相交面积 = 圆环1外圆和圆环2外圆的相交面积 - 圆环1外圆和圆环2内圆的相交面积 - 圆环1内圆和圆环2外圆的相交面积 + 圆环1内圆和圆环2内圆的相交面积。

思路:ans = 大大+小小-2*大小,(大大指大圆和大圆相交的面积)。

# include <iostream>
# include <cstdio>
# include <cmath>
# define eps 1e-8
# define PI acos(-1.0)
using namespace std;
 
double distance(double x0, double y0, double x1, double y1)
{
    return sqrt((x0-x1)*(x0-x1)+(y0-y1)*(y0-y1));
}
 
double area(double dis, double r1, double r2){
    double d=dis;
    if(r1+r2<d+eps) return 0;
    if(d<fabs(r1-r2)+eps){
        double r=min(r1,r2);
        return PI*r*r;
    }
    double x=(d*d+r1*r1-r2*r2)/(2*d);
    double t1=acos(x/r1);
    double t2=acos((d-x)/r2);
    return r1*r1*t1+r2*r2*t2-d*r1*sin(t1);
}
 
int main()
{
    int t, cas=1;
    double r, R, x0, y0, x1, y1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf%lf%lf%lf%lf%lf",&r,&R,&x0,&y0,&x1,&y1);
        double dis = distance(x0, y0, x1, y1);
        double ans = area(dis, R, R)+area(dis, r, r)-2*area(dis, r, R);
        printf("Case #%d: %.6f\n",cas++, ans);
    }
    return 0;
}


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值