Intersection (圆环相交的面积,两圆相交面积模板)

Matt is a big fan of logo design. Recently he falls in love with logo made up by rings. The following figures are some famous examples you may know. 


A ring is a 2-D figure bounded by two circles sharing the common center. The radius for these circles are denoted by r and R (r < R). For more details, refer to the gray part in the illustration below. 


Matt just designed a new logo consisting of two rings with the same size in the 2-D plane. For his interests, Matt would like to know the area of the intersection of these two rings.

Input

The first line contains only one integer T (T ≤ 10 5), which indicates the number of test cases. For each test case, the first line contains two integers r, R (0 ≤ r < R ≤ 10). 

Each of the following two lines contains two integers x i, y i (0 ≤ x i, y i ≤ 20) indicating the coordinates of the center of each ring.

Output

For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y is the area of intersection rounded to 6 decimal places. 

Sample Input

2
2 3
0 0
0 0
2 3
0 0
5 0

Sample Output

Case #1: 15.707963
Case #2: 2.250778

题意:给了两个同心圆环,内半径为 r1 , 外半径为 r2。 然后给出这两个圆环的圆心,问相交的面积是多少?

思路:要求两个圆环相交的面积,其实可以用  两个大圆的相交的面积 -  一个大圆和一个小圆的相交的面积  -  一个小圆和一个大圆的相交的面积 + 两个小圆相交的的面积。那么我们只需要套用两个圆相交的面积的模板即可。

#include<cstdio>
#include<cstring>
#include<cmath>
#include<iostream>
#include<algorithm>
using namespace std;
const double eps=1e-5;
double pi=acos(-1.0);
struct node
{
    double x,y;
};
double len(double x1,double y1,double x2,double y2)
{
    double l=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2)+0.0);
    return l;
}
double Area(node c1,double r1,node c2,double r2)
{
    double d=len(c1.x,c1.y,c2.x,c2.y);
    if(r1+r2<d+eps)return 0;
    if(d<fabs(r1-r2)+eps)
    {
        double r=min(r1,r2);
        return pi*r*r;
    }
    double x=(d*d+r1*r1-r2*r2)/(2*d);
    double t1=acos(x/r1);
    double t2=acos((d-x)/r2);
    return r1*r1*t1+r2*r2*t2-d*r1*sin(t1);
}

int main()
{
    int t,cas=1;
    cin>>t;
    while(t--)
    {
        double r1,r2;
        node a,b;
        cin>>r1>>r2;
        double x1,y1,x2,y2;
        cin>>a.x>>a.y>>b.x>>b.y;
        double s=Area(a,r2,b,r2)-Area(a,r1,b,r2)-Area(a,r2,b,r1)+Area(a,r1,b,r1);
        printf("Case #%d: %.6lf\n",cas++,s);
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值