1002 A+B for Polynomials (25 分)

1002 A+B for Polynomials (25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2
  • 主要存在几个点:
      可以输入重复的项
      输入的项相加后可能为0,此时项数减1
      当项目为0时,只输出项数,不要加空格
      输出最后一项不要加空格
      最终的结果多项式项数最多为20
  • #include<bits/stdc++.h>
    using namespace std;
    vector<vector<double> >q;
    map<int,int>p;
    map<int,int>::iterator it;
    struct st
    {
        int x;
        double y;
    } a[1010];
    int main()
    {
        int n,m;
        p.clear();
        scanf("%d",&n);
        q.resize(1010);
        for(int i=0; i<n; i++)
        {
            int x;
            double y;
            cin>>x>>y;
            q[x].push_back(y);
            p[x]=1;
        }
        cin>>m;
        for(int i=0; i<m; i++)
        {
            int x;
            double y;
            cin>>x>>y;
            q[x].push_back(y);
            p[x]=1;
        }
        int r=0;
        for(it=p.begin(); it!=p.end(); it++)
        {
            double k=0;
            int t=it->first;
            for(int j=0; j<(int)q[t].size(); j++)
            {
                k+=q[t][j];
            }
            if(k!=0)
            {
                r++;
                a[r].x=t;
                a[r].y=k;
            }
        }
        printf("%d",r);
        for(int i=r; i>=1; i--)
            printf(" %d %.1lf",a[i].x,a[i].y);
        cout<<endl;
        return 0;
    }
    

     

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值